Guru do Excel + Power BI

Sua dose diária de Power BI e Excel

Qualquer dúvida sobre gráficos, como criá-los, alterar eixos principais e secundários, adicionar/remover categorias e séries, legendas e rótulos, etc.
  • Avatar do usuário
Por perina
#69573
Bom dia, pessoal. Espero que estejam bem.

É meu primeiro post aqui no grupo, se eu estive infringindo alguma regra, me desculpem. Qualquer coisa, eu excluo e refaço da maneira correta.

Minha situação é assim.

Tenho na Coluna AM, a somatória total de toda uma pontuação, porém, existe algumas condições, que se ocorrerem, essa pontuação pode baixar ou pode aumentar, porém, não estou conseguindo finalizar a formula.

As regras que quero inserir são:
Se a coluna AG for sim, zerar toda a pontuação da coluna AM.
Se a coluna AH for sim, retirar 50% da pontuação total da coluna AM.
Se a coluna AI for sim, retirar 10% da somatória total da coluna AM.
Se a coluna AJ, AK e AL forem sim, realizar a somatória.

A formula feita até então, foi essa:

=SEERRO(SE(E(AG5="Não";AH5="Não");((AF5+AD5+AB5+X5+V5+T5+Q5+O5+M5+K5+I5+F5)*2);SE(E(AG5="Não";AH5="Sim");((AF5+AD5+AB5+X5+V5+T5+Q5+O5+M5+K5+I5+F5)-0,5);((AF5+AD5+AB5+X5+V5+T5+Q5+O5+M5+K5+I5+F5)*0)));0)

Porém, travei ai e não consigo sair dessa parte.

Me desculpem pelo texto longo.
#69581
Vamos por partes.
Em quatro situações o valor da soma será zerado.
Se tivermos em um das colunas AJ, AK, AL = Não ___>>> Soma será zerada
Se tivermos "Sim" na coluna AG ___>>> Soma será zerada.
Se AH = "Sim", tiramos 50% da pontuação.
Se AI = "Sim", tiramos 10% da pontuação.

Considerando para calcular o valor total da pontuação a fórmula abaixo:
=SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)

Insira a fórmula abaixo na coluna AM e simula as situações para verificar.

=SE(E(E(E(AJ4="Sim";AK4="Sim";AL4="Sim";AG4="Não")));SE(AH4="Sim";SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)*0,5;SE(AI4="Sim";SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)*0,9;SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4))))
#69583
Use esta fórmula.
=SE(E(E(E(AJ4="Sim";AK4="Sim";AL4="Sim";AG4="Não")));SE(AH4="Sim";SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)*0,5;SE(AI4="Sim";SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)*0,9;SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)));0)
#69593
Fiz as simulações possíveis e o cálculo está correto.
Segue a planilha anexo. Lembrando que está sobre estas condições:
Considerando para calcular o valor total da pontuação a fórmula abaixo:
=SOMA(F4;I4;K4;M4;O4;Q4;T4;V4;X4;AB4;AD4;AF4)

Se tivermos em uma das colunas AJ, AK, AL = Não e AG = Sim ___>>> Pontuação será zerada
Se AH = "Sim", tiramos 50% da pontuação.
Se AI = "Sim", tiramos 10% da pontuação.

Tais condicionais vieram da sua explicação:
As regras que quero inserir são:
Se a coluna AG for sim, zerar toda a pontuação da coluna AM.
Se a coluna AH for sim, retirar 50% da pontuação total da coluna AM.
Se a coluna AI for sim, retirar 10% da somatória total da coluna AM.

Se a coluna AJ, AK e AL forem sim, realizar a somatória. AJ, AK, AL = SIM E AG = NÃO -> Haverá cálculo, se uma delas for diferente vai ser 0 o resultado. Se AG = Sim ou AJ, AK, AL = Sim em alguma delas, resulta será 0.
Você não está autorizado a ver ou baixar esse anexo.

https://i.imgur.com/SDRkGNP.jpg

Boa tarde, pessoal. Com o auxílio de um v&[…]

Private Sub Worksheet_Change(ByVal Target As Rang[…]

https://datebest.net - visit website and win smart[…]

Não sei se entendi, mas tente mudar: De: #[…]

Tente: Valores = CALCULATE ( SUM ( Tabela[VALOR][…]

https://t.me/pump_upp - best crypto pumps on teleg[…]

Boa tarde! Foxtri Os códigos não fu[…]