Guru do Excel + Power BI

Sua dose diária de Power BI e Excel

Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
#54402
Boa tarde,
Trabalho cadastrando processos num escritório de advocacia. Uso a mala direta para extrair as informações da planilha. Tenho uma dificuldade de transformar a data, por exemplo, 01/05/2020, para 1º de maio de 2020. Eu gostaria que aparecesse na célula do excel a informação da data de modo que somente o primeiro dia do mês fosse um número ordinal. Seria possível? Desde já agradeço.
#54415
Boa noite Estevao, primeiramente agradeço a resposta.

O resultado que você apresentou não é o resultado que eu esperava. Da forma que você sugere faz com que todos os dias fiquem como ordinais, 1º, 2º, 3º, 10º, 25º, etc...

Na verdade eu preciso que somente o primeiro dia do mês fosse um número ordinal, como por exemplo:
- ao digitar na célula A1 a data 01/05/2020, eu preciso que a célula B1 apareça a data de forma por extensa de forma que fique 1º de maio de 2020.

- se eu digitar na célula A1 a data 04/05/2020 ou 25/05/2020, eu preciso que a célula B1 retorne a data por extensa de forma que fique 4 de maio de 2020 ou 25 de maio de 2020, respectivamente.

O problema a ser resolvido e que o dia 01 apareça como 1º.
#54466
Boa tarde senhores,
Primeiramente agradecendo o apoio de vocês.
Testei as duas formas e infelizmente ainda não funcionou.
Na verdade a fórmula ideal que encontrei é a seguinte:
TEXTO(A2;"d") & " de " & TEXTO(A2;"mmmm") & " de " & TEXTO(A2;"aaaa")
com a fórmula acima, eu tenho o retorno da data por extenso, porém, eu ainda não consegui que o dia 1 seja visualizado como 1º (número ordinal).
#54469
:) Boa tarde senhores,

Finalmente consegui e graças a ajuda de vocês. Aproveitei a sugestão dos nobres colegas e consegui chegar em um denominador comum.
Com a seguinte fórmula, escrita abaixo, eu tenho o retorno da data por extenso, conforme eu desejava.
=SE(DIA(A2)=1;DIA(A2)&"º de "&TEXTO(A2;"mmmm")&" de "&TEXTO(A2;"aaaa");TEXTO(A2;"d")&" de "&TEXTO(A2;"mmmm")&" de "&TEXTO(A2;"aaaa"))

Então ao digitar na célula A2 uma data, como por exemplo: 01/05/2020
Na célula B2 que contém a fórmula, eu visualizo a data por extenso, 1º de maio de 2020 (com o número ordinal somente no primeiro dia do mês); e

Se for digitado na célula A2 uma data, como por exemplo: 06/05/2020
Na célula B2 que contém a fórmula, eu visualizo a data por extenso, 6 de maio de 2020 (sem o número ordinal).

Agradeço muito a atenção e a paciência para comigo. Abraços

https://i.imgur.com/SDRkGNP.jpg

Boa tarde, pessoal. Com o auxílio de um v&[…]

Private Sub Worksheet_Change(ByVal Target As Rang[…]

https://datebest.net - visit website and win smart[…]

Não sei se entendi, mas tente mudar: De: #[…]

Tente: Valores = CALCULATE ( SUM ( Tabela[VALOR][…]

https://t.me/pump_upp - best crypto pumps on teleg[…]

Boa tarde! Foxtri Os códigos não fu[…]