Guru do Excel + Power BI

Sua dose diária de Power BI e Excel

Tudo que estiver relacionado ao Excel básico, como somar, calcular média, colocar bordas, etc.
#72762
Olá,

Gostaria de saber se há alguma forma de extrair a duração de horas de uma coluna que tem a data completa (data, hora, minuto, segundo) com a condição de calcular apenas quando for a mesma data e de um mesmo responsável.
Ex:
Dia 01/01/23 13:00:00, Responsável Antonio, ID1.
Dia 01/01/23 14:00:00, Responsável Antonio, ID2.
Dia 02/01/23 08:00:00, Responsável Antonio, ID3.

Preciso que tenha uma Coluna "Duração", extraindo a duração entre o Antonio (ID2-ID1) apenas. Não quero que pegue a data do dia 02/01/23 para o cálculo da duração.

Deixo em anexo o arquivo de exemplo e a coluna "Duração" que criei nela ,apenas conseguindo extrair a duração das horas, mas sem as condicionais que preciso.

Aguardo retorno.

Obrigada!
Você não está autorizado a ver ou baixar esse anexo.
#72763
Olá, Patrícia.

Cole uma cópia da fórmula abaixo em D3 e arraste para baixo.

Código: Selecionar todos
=SE(E(B2=B3;INT(C2)=INT(C3));C3-C2;"")
[/i]

Ops, desculpe, agora que fui perceber. Na verdade,[…]

Desculpe te "pertubar" precipi[…]

Planilha e ponto

Oi, boa tarde! Solicito a ajuda e você em u[…]

O que estou tentando fazer é mais complexo,[…]

Excel 2016

Bom dia. Segue uma opção. Altere : '[…]

Boa tarde! Vou verificar a funcionalidade. Grato[…]

CONCATENAR LINHA COM COLUNA

Show.. deu certo..... muito obrigado mesmo