Guru do Excel + Power BI

Sua dose diária de Power BI e Excel

Pesquisa resultou em 1254 ocorrências

 Voltar para a pesquisa avançada

Re: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS

 por Estevaoba ¦  21 Jan 2023 às 16:26 ¦  Fórum: Fórmulas e Funções ¦  Tópico: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS ¦  Respostas: 6 ¦  Exibições: 192

Consegui simplificar a fórmula, sem as funções do Excel 365 e sem usar a sua tabela F1:G5: =SE(DIA.DA.SEMANA(B1)=2;"Técnico "&ÍNDICE({"Paulo";"Luiz";"Silas";"Augusto";"Almir"};CORRESP(MOD(QUOCIENTE($B$1-DATA(ANO(A1);MÊS(A1);ESCOLHER(DIA...

Re: Menu recolher e expandir dentro de Tabela? 🤯

 por Estevaoba ¦  21 Jan 2023 às 14:10 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Menu recolher e expandir dentro de Tabela? 🤯 ¦  Respostas: 2 ¦  Exibições: 122

Boa tarde. Bem-vindo ao fórum. Segue um exemplo utilizando o recurso Estrutura de tópicos, no menu Dados do Excel. Instruções nesta página. https://support.microsoft.com/pt-br/office/organizar-agrupar-dados-em-uma-estrutura-de-t%C3%B3picos-em-uma-planilha-08ce98c4-0063-4d42-8ac7-8278c49e9aff?ns=exce...

Re: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS

 por Estevaoba ¦  21 Jan 2023 às 13:53 ¦  Fórum: Fórmulas e Funções ¦  Tópico: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS ¦  Respostas: 6 ¦  Exibições: 192

Segue uma fórmula usando apenas as informações das células A1 e B1, e com matrizes virtuais criadas dentro das funções LET e SEQUÊNCIA, disponíveis na versão Excel 365 ou postrerior. =SEERRO("Técnico "&LET(Seg;DATA(ANO(A1);MÊS(A1);ESCOLHER(DIA.DA.SEMANA(DATA(ANO(A1);MÊS(A1);1));2;1;7;6...

Re: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS

 por Estevaoba ¦  20 Jan 2023 às 20:58 ¦  Fórum: Fórmulas e Funções ¦  Tópico: ALTERNANDO EM LOOP AS MENSAGENS AS SEGUNDAS-FEIRAS ¦  Respostas: 6 ¦  Exibições: 192

Boa noite.

Acredito que você terá uma tabela com as datas futuras e seus respectivos técnicos.
Assim, criei uma tabela com dados progressivos a partir dos dados iniciais e fiz a fórmula conforme solicitado.
Confira se atende.

Good luck!

Re: Transformar código em data

 por Estevaoba ¦  19 Jan 2023 às 12:47 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Transformar código em data ¦  Respostas: 2 ¦  Exibições: 112

Olá.
Cole em B2 e arraste para baixo:

Código: Selecionar todos
=DATA(20&ESQUERDA(DIREITA(A2;6);2);EXT.TEXTO(DIREITA(A2;6);3;2);DIREITA(DIREITA(A2;6);2))
Good luck!

Tente esta:

Código: Selecionar todos
=TEXTO(C1-ÍNDICE({1;2;0;1;0;1;0};CORRESP(DIA.DA.SEMANA(C1);COL(A1:G1);0));"dd/mm/aaaa")&" - CONCURSO - "&DIATRABALHOTOTAL.INTL(A1;C1;"1010101")+B1-1
Ab.

Re: exibir denominador de uma fração

 por Estevaoba ¦  17 Jan 2023 às 15:18 ¦  Fórum: Outros Assuntos ¦  Tópico: exibir denominador de uma fração ¦  Respostas: 1 ¦  Exibições: 144

Considerando o resultado na célula A7, experimente:

Código: Selecionar todos
=VALOR(DIREITA(TEXTO(MOD(A7;1);"#/#");NÚM.CARACT(TEXTO(MOD(A7;1);"#/#"))-LOCALIZAR("/";TEXTO(MOD(A7;1);"#/#"))))
Good luck!

Código: Selecionar todos
=TEXTO(C1;"dd/mm/aaaa")&" - CONCURSO - "&SE(OU(DIA.DA.SEMANA(C1)={3;5;7});DIATRABALHOTOTAL.INTL(A1;C1;"1010101")+B1-1;" HOJE NÃO")
Good luck!

Re: Ordenar os números em ordem crescente.

 por Estevaoba ¦  24 Dez 2022 às 17:57 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Ordenar os números em ordem crescente. ¦  Respostas: 4 ¦  Exibições: 233

Boa tarde.
Eu removi na fórmula do Decio o maior valor de cada matriz e um valor do formato da função TEXTO.

Código: Selecionar todos
=TEXTO(SOMARPRODUTO(MENOR(0+EXT.TEXTO(SUBSTITUIR(A1;" ";REPT(" ";25));25*{0;1;2;3;4;5}+1;25);{1;2;3;4;5;6});10^{10;8;6;4;2;0});"00 00 00 00 00 00")

Good luck!

Re: Histórico Salárial

 por Estevaoba ¦  20 Dez 2022 às 21:39 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Histórico Salárial ¦  Respostas: 3 ¦  Exibições: 306

Código: Selecionar todos
=ÍNDICE('Cad1'!G10:G12;CORRESP(B8;('Cad1'!C10:C12)*('Cad1'!E10:E12=C8);1))
Good luck!

Re: Calcular em dias e horas o resultado

 por Estevaoba ¦  20 Dez 2022 às 20:12 ¦  Fórum: Fórmulas e Funções ¦  Tópico: RESOLVIDO!! Calcular em dias e horas o resultado ¦  Respostas: 2 ¦  Exibições: 319

=INT(SOMA(SOMA(C3;D3);QUOCIENTE(E3;B3);MOD(E3;B3);QUOCIENTE(F3;B3);MOD(F3;B3)))&" Dias"&SE(MOD(SOMA(SOMA(C3;D3);QUOCIENTE(E3;B3);MOD(E3;B3);QUOCIENTE(F3;B3);MOD(F3;B3));1)=0;"";" e "&TEXTO(MOD(SOMA(SOMA(C3;D3);QUOCIENTE(E3;B3);MOD(E3;B3);QUOCIENTE(F3;B3);MO...

Re: Soma vinculada a 03 diferentes condições (parâmetros)

 por Estevaoba ¦  19 Nov 2022 às 23:46 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Soma vinculada a 03 diferentes condições (parâmetros) ¦  Respostas: 5 ¦  Exibições: 217

Outra opção, complementando a ideia do Eric:

Código: Selecionar todos
=SOMA(ÍNDICE($D$4:$O$7;CORRESP(C11;$C$4:$C$7;0);CORRESP(C9&C10;$D$2:$O$2&$D$3:$O$3;0)):ÍNDICE($D$4:$O$7;CORRESP(C11;$C$4:$C$7;0);CORRESP(C9&C10;$D$2:$O$2&$D$3:$O$3;0)+CONT.SES($D$2:$O$2;C9;$D$3:$O$3;C10)-1))
Good luck!

Re: Contar sequencia depois de determinado valor

 por Estevaoba ¦  19 Nov 2022 às 23:23 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Contar sequencia depois de determinado valor ¦  Respostas: 4 ¦  Exibições: 165

Se puder usar coluna auxiliar, tente com esta fórmula em K2, por exemplo, copiada para baixo:

Código: Selecionar todos
=SEERRO(SE(E(A1="Uva";A2="Pera");1;SE(E(A1="Pera";A2="Pera");K1+1;""));"")
Depois use esta:
=CONT.SE(K2:K29;5)

Good luck!

Re: Extrair a parte fracionária de um número %

 por Estevaoba ¦  07 Nov 2022 às 14:36 ¦  Fórum: Fórmulas e Funções ¦  Tópico: [RESOLVIDO] Extrair a parte fracionária de um número % ¦  Respostas: 2 ¦  Exibições: 81

Código: Selecionar todos
=MOD(SE(OU([@[Valor Atual]]="";[@Alvo]="");"";SOMA([@Alvo]-[@[Valor Atual]])/[@[Valor Atual]])*100;1)/100
Good luck!

Re: Fórmula que retorna número da Nota

 por Estevaoba ¦  07 Nov 2022 às 14:29 ¦  Fórum: Fórmulas e Funções ¦  Tópico: [RESOLVIDO] Fórmula que retorna número da Nota ¦  Respostas: 5 ¦  Exibições: 120

Boa tarde. Sua fórmula estava com referência à primeira célula na matriz da CORRESP, por isso o erro. Segue a sintaxe correta. Se seu Excel for versão anterior a 365, confirmar com Ctrl+Shift+Enter, em vez de apenas Enter. =ÍNDICE(TB_NotasCorretagem[Nota];CORRESP(B8&C8;TB_NotasCorretagem[Data]&a...

Re: Excel - Formula para retorno de dados de duas planilhas

 por Estevaoba ¦  07 Nov 2022 às 14:12 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Excel - Formula para retorno de dados de duas planilhas ¦  Respostas: 2 ¦  Exibições: 80

Boa tarde. Creio que você pode fazer isso usando a função INDIRETO. Para facilitar a elaboração e teste de possíveis soluções, favor postar um modelo com algumas linhas representativas da sua planilha, colocando manualmente os resultados esperados e explicando por que devem ser dessa forma. Clique e...

Bem-vindo ao fórum. Para facilitar a elaboração e teste de possíveis soluções, favor postar um modelo com algumas linhas representativas da sua planilha, colocando manualmente os resultados esperados e explicando por que devem ser dessa forma. Clique em +Resposta, Adicionar um anexo, Adicionar arqui...

Re: Tarefa existe na semana escolhida?

 por Estevaoba ¦  30 Set 2022 às 08:22 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Tarefa existe na semana escolhida? ¦  Respostas: 12 ¦  Exibições: 392

Sim, eu adaptei aproveitando a lógica de uma fórmula criada pelo Xlent. Funcionou para exibir os resultados como zero e um, mas por algum motivo que desconheço ela não funciona na formatação condicional.

Ab.

Re: Tarefa existe na semana escolhida?

 por Estevaoba ¦  29 Set 2022 às 22:48 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Tarefa existe na semana escolhida? ¦  Respostas: 12 ¦  Exibições: 392

Boa noite. Não consegui adaptar a fórmula para a formatação condicional. A dificuldade é mais porque não entendo totalmente a dinâmica dos cálculos para chegar no resultado correto. Por exemplo, na barra de fórmulas o resultado exibido é zero para todas as linhas. Mas ao confirmar com Enter, o resul...

Re: Extração de Inicias sem considerar a preposição

 por Estevaoba ¦  28 Set 2022 às 09:31 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Extração de Inicias sem considerar a preposição ¦  Respostas: 2 ¦  Exibições: 72

=EXT.TEXTO(SUBSTITUIR(SUBSTITUIR(A1;"da ";"");"de ";"");1;1)&"."&+EXT.TEXTO(SUBSTITUIR(SUBSTITUIR(A1;"da ";"");"de ";"");PROCURAR(" ";SUBSTITUIR(SUBSTITUIR(A1;"da ";"");&q...

  • 1
  • 2
  • 3
  • 4
  • 5
  • 63

Ops, desculpe, agora que fui perceber. Na verdade,[…]

Desculpe te "pertubar" precipi[…]

Planilha e ponto

Oi, boa tarde! Solicito a ajuda e você em u[…]

O que estou tentando fazer é mais complexo,[…]

Excel 2016

Bom dia. Segue uma opção. Altere : '[…]

Boa tarde! Vou verificar a funcionalidade. Grato[…]

CONCATENAR LINHA COM COLUNA

Show.. deu certo..... muito obrigado mesmo