Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por JulioLopes 13 Jul 2019 às 15:04
Membro Novato
Mensagens: 2
Reputação: 0
#45547
Olá amigos.
Atualmente tenho uma dificuldade em meu novo estágio, pois estou realizando checklist em planilhas do excel e muitas das vezes tendo que realizar um cálculo ''manual'' para tal resultado.

Gostaria de saber a possibilidade de criação de uma função ou fórmula que automaticamente esse somatório final seja realizado sem a necessidade da intervenção manual.
Em anexo está um exemplo da planilha que utilizamos.
Apenas usuários registrados podem ver ou baixar anexos.
Por babdallas 13 Jul 2019 às 20:14
Membro 5 Estrelas
Mensagens: 1749
Reputação: 777
#45549
Veja se é isso.

Código: Selecionar todos=SOMARPRODUTO(ÍNDICE($E$4:E20;AGREGAR(15;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");CONT.SE($D$4:$D20;"<>"&"")*2+1)+1):ÍNDICE($E$4:E20;AGREGAR(14;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");1)-1))
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Deciog 14 Jul 2019 às 09:57
Membro 5 Estrelas
Mensagens: 1175
Reputação: 586
#45554
JulioLopes , Bom Dia.

Uma outra forma de fazer confere

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.