Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Saulo 17 Mai 2019 às 12:02
Membro 1 Estrela
Mensagens: 11
Reputação: 0
#43935
Bom Dia!
Na planilha “Registro de Exames” existem duas colunas com nomes “EXAME” e “MUNICIPIO” respectivamente nas colunas “A” e “B”.
Pedido de Ajuda: Que nas colunas “F” e “G” da planilha “Registro de Exames” associem os esses dados aos pré existentes nas colunas “H” e “I” na planilha “Parametros do Sistema”.
Por exemplo: Na coluna “F” da planilha “Registro de Exames” deverá constar o valor de R$ 400,00 e na coluna “G” o valor 20, ambos como cadastrados na planilha “Parametros do Sistema” respectivamente na células “H13” e “I13”, e assim sucessivamente.
Anexo Planilha Para Análise.
Desde já agradeço.
Atenciosamente
Apenas usuários registrados podem ver ou baixar anexos.
Por Kledison 17 Mai 2019 às 13:48
Excel Expert
Mensagens: 750
Reputação: 306
#43945
Bom dia,

na célula F7 (Valor unitário do Exame) da aba Registro de Exames, coloque essa fórmula e arraste baixo e para a coluna G7:

Código: Selecionar todos=SOMARPRODUTO(('Parametros do Sistema'!$F$4:$F$27='Registro de Exames'!$A7)*('Parametros do Sistema'!$G$4:$G$27='Registro de Exames'!$B7)*'Parametros do Sistema'!I$4:I$27)




Att
Por babdallas 17 Mai 2019 às 13:48
Membro 5 Estrelas
Mensagens: 1602
Reputação: 718
#43946
Veja se atende.
Apenas usuários registrados podem ver ou baixar anexos.
Por Saulo 20 Mai 2019 às 12:20
Membro 1 Estrela
Mensagens: 11
Reputação: 0
#44015
Prezado babdallas 17 Mai 2019 às 12:48, Bom dia!
Excelente Solução!
Você Poderia Explicar-me Como Fez os Seguintes Desenvolvimentos:
1) Na planilha “Registro de Exames” a cada inclusão de dados, às células se alternam entre as cores Azul e Branco, e as bordas das células úteis são formatadas automaticamente;
2) As fórmulas das colunas “F” e “G” da planilha “Registro de Exames” são replicadas automaticamente a cada inclusão? Se sim, como fazer essa rotina de replicar os dados sem recursos de “copiar / colar” ou puxar os dados células abaixo.
Desde já agradeço pela solução / resolução da demanda.
Atenciosamente