Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por Saulo
#67462
Boa Tarde!
Tenho a seguinte fórmula na coluna L: =SE(A7<>"";CONT.VALORES($A$7:A7)&"/"& TEXTO(B7;"aaaa");"").
Teria alguma possibilidade dessa contagem ser reiniciada a cada virada de ano, ou seja, ao fim do ano de 2021 por exemplo ficaria assim: 272/2021 e quando iniciar o ano de 2022 o primeiro registro seria: 1/2022 e assim sucessivamente para os demais registros e anos vindouros.
Desde já agradeço
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por Saulo em 15 Out 2021 às 14:48, em um total de 1 vez.
Avatar do usuário
Por Foxtri
#67469
Olá
Veja se serve.
Na Coluna L
=SE(A7<>"";SEERRO(SE(ANO(B6)=ANO(B7);S6+1;(S6*0)+1);1)&"/"& TEXTO(B7;"aaaa");"")

Até
Foxtri
Saulo agradeceu por isso
Por Saulo
#67480
Boa Tarde Foxtri - 13 Out 2021 às 16:45!
Então.... o resultado não foi o esperado, Talvez Eu Não tenha me expressado corretamente, peço desculpas.
Atualmente funciona assim: o lado esquerdo da barra (/) é povoado através da função CONT.VALORES e o lado direito da barra (/) ´povoado com a função TEXTO, como resultado, a direita da barra (/) tem-se uma contagem de números de registro da coluna “A” e a esquerda da barra tem-se o ano obtido da coluna “B”.
Se for possível, o ideal é que o numeral tenha o sequencial indexado ao ano, ou seja, ano 2017 (1/2017 até xxx/2017); ano 2018 (1/2018 até xxx/2018) e assim sucessivamente de acordo com as entradas de dados.
Caso tenha outra alternativa e/ou sugestão as funções CONT.VALORES e TEXTO por hora utilizada, será bemvinda.
Desde já Agradeço
Por babdallas
#67481
Código: Selecionar todos
=SE(A7<>"";CONT.SE($K$7:K7;K7)&"/"& TEXTO(B7;"aaaa");"")
Você não está autorizado a ver ou baixar esse anexo.
Saulo, PauloSouza897 agradeceu por isso
Por Saulo
#67495
Bom Dia babdallas - 14 Out 2021 às 16:15
Era Isso Mesmo, Show de Bola!
Muito Obrigado.

Bom dia Para saber o número de linhas com V[…]

Olha só, sem vc anexar uma planilha exemplo[…]

Pessoal, gostaria de uma ajuda de vocês se p[…]

[AJUDA]VBA Crashando

up

Fórmula para contagem

Segue abaixo um exemplo

SOMAR PRODUTOS

Junqueira, desculpa a demora . obrigado. perfeito

Boa tarde. Com a ajuda de um membro do fór[…]