Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Por bhashizumi
#63537
Boa tarde pessoal!
Fiz um PROCV na planilha abaixo para buscar o valor do ativo na semana anterior. Quando eu uso o resultado para fazer qualquer conta ele me volta "#valor" como na celula k298 na imagem.
Alguém pode me ajudar por favor?
Imagem
Por babdallas
#63543
Anexa uma planilha Excel como exemplo, por favor.
Avatar do usuário
Por Estevaoba
#63556
Sem um modelo da sua planilha para testar fórmulas fica difícil, mas não creio que essa fórmula funcione corretamente, pois ela busca valores concatenados de duas colunas (B & D) em uma única coluna (A). Eu usaria desta outra forma:
Código: Selecionar todos
=ÍNDICE(F:F;CORRESP(B298-7&D298;A:A&D:D;0))
Fórmula matricial. Se o seu Excel for anterior ao 365, confirme com Ctrl+Shift+Enter em vez de apenas Enter.

Good luck!
bhashizumi agradeceu por isso
Por bhashizumi
#63587
Foi mal.. Nem pensei em adicionar o anexo.. Vou mandar aqui..
A Formula matricial também não deu certo!
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#63595
bhashizumi escreveu: 07 Abr 2021 às 13:55 ... qualquer conta ele me volta "#valor" como na celula k298 na imagem.
Em K298:
Código: Selecionar todos
=SUBSTITUIR(SUBSTITUIR(J298;",";"");".";",")-SUBSTITUIR(SUBSTITUIR(F298;",";"");".";",")
bhashizumi agradeceu por isso
Avatar do usuário
Por Deciog
#63600
bhashizumi, Bom Dia.

No seu exemplo com valores expressos em Inglês, eu usaria desta forma na célula K298

Para a versão Excel antes de 2019, feche com CTRL + SHIFT + ENTER, são formula matricial

=INT(VPL(-0,9;SEERRO(EXT.TEXTO(J298;1+NÚM.CARACT(J298)-LIN(INDIRETO("1:"&NÚM.CARACT(J298)));1)/10;"")))/100-INT(VPL(-0,9;SEERRO(EXT.TEXTO(F298;1+NÚM.CARACT(F298)-LIN(INDIRETO("1:"&NÚM.CARACT(F298)));1)/10;"")))/100

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Atividade renumerada!!!!

Vai neste fórum, neste voce pode postar e p[…]

Na figura 1 é a aparência quando abro[…]

Cara, nem sei como agradecer. Showww, resolveu per[…]

repetição entre jogos

Poderia dar alguns exemplo de resultado esperado s[…]

Mudar o mês na fórmula

Anexa um exemplo, por favor.

Não seria só desabilitar a opç[…]

Ajuda Para Calculo com horario.

Bom dia/tarde/noite Pessoal preciso de uma ajuda[…]

Agradeço muito pela dica, mas acredito que […]