Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
#62414
Boas, tenho o seguinte ficheiro, que contem 2 tabelas.

Quero identificar o valor na primeira tabela, baseado na segunda tabela.

Para isso criei um código único para cada linha.

Problema: Nesse código único ele pega a quantidade da tabela 1, mas na tabela 2 essa quantidade(em alguns casos pode variar, ser maior ou menor), fazendo com que o código único seja diferente e não associando assim o identificador.



Ficheiro em anexo, mais explicado e com exemplo.



Obrigado!
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por AfonsoMira em 23 Fev 2021 às 09:14, em um total de 1 vez.
#62416
AfonsoMira, Bom Dia.

Usa desta forma

=SEERRO(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP(PROCV(D2;TbIdentificadores!$D$2:$D$11;1;0);TbIdentificadores!$D$2:$D$11;0));(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP((PROCV(D2;TbIdentificadores!$D$2:$D$11;1;1));TbIdentificadores!$D$2:$D$11;0))))

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
AfonsoMira agradeceu por isso
#62417
Salve, @AfonsoMira

Experimente esta matricial.
Código: Selecionar todos
=ÍNDICE(TbIdentificadores!A$2:A$11;CORRESP(MÍNIMO(ABS(D2-(TbIdentificadores!D$2:D$11)));ABS(D2-(TbIdentificadores!D$2:D$11));0))
AfonsoMira agradeceu por isso
#62418
@Deciog É exatamente isso, muito obrigado. :)
Deciog agradeceu por isso
#62419
@osvaldomp, A sua também funcionou.
Obrigado :)
osvaldomp agradeceu por isso

o problema está no fato de vc ter agrupamen[…]

Botão delete

Obrigado pela ajuda (y) :) Saudaçõe[…]

Formatação para impressão de etiquetas

é bem chatinho isso pois os dados nessa col[…]

Contagem de dados repetidos

Seguem 2 opções. eu queria ente[…]

procurar e inserir linhas

se eu entendi bem, vc quer uma macro que te arrume[…]

Atualizar Fonte de Dados da Tabela Dinâmica

fico contente que tenha dado certo. Não do[…]

não sei se já resolveu, mas as linha[…]

Renomear arquivos

tem um jeito meio maluco, vc poderia fazer uma cha[…]