Tópicos relacionados a códigos VBA, gravação de macros, etc.
Por Diego100ges
#61485
Pessoal, boa tarde.

Estou tendo um problema em um laço for, que é o seguinte, eu disparo um e-mail através de uma sub com base nos clientes que estavam tickados no check box da listview.
Porém na assinatura do respectivo que fica em outra sub, acontece de pegar as informações da assinatura do ultimo cliente selecionado, e não respectivo cada cliente com os dados do seu gestor na assinatura.

Será que é algo errado com o código?
Código: Selecionar todos
Sub assinatura_email(Assinatura)

For i = 1 To Me.lista_clientes.ListItems.Count

If Me.lista_clientes.ListItems.Item(i).Checked = True Then

Gestor = Me.lista_clientes.ListItems.Item(i).SubItems(6)
EmailGestor = Me.lista_clientes.ListItems.Item(i).SubItems(7)
TelefoneGestor = Me.lista_clientes.ListItems.Item(i).SubItems(8)

Assinatura = "texto"
Assinatura = Assinatura & "texto" & Gestor 
Assinatura = Assinatura & "texto" & Email
Assinatura = Assinatura & "texto" & Telefone

End If

Next i

End Sub

Veja se atende. Selecione B4:G7 | menu Pág[…]

Ajuda sobre Formulario

mano valeu muito, deu certo coloquei em todos as l[…]

DataAtual + NºSérie

Entendi. Obrigado novamente pela explicaç&a[…]

@Angra , o botão para marcar resolvido[…]

Quero comparar as colunas sim, que neste caso s&[…]

Achei a dúvida bem interessa mas acho que o[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]