Tópicos relacionados a códigos VBA, gravação de macros, etc.
Por Diego100ges
#61475
Pessoal, boa tarde.

Gostaria de tirar uma duvida com vocês, eu tenho uma variavel que recebe código html, uma assinatura de email pra ser mais exato, porém da forma que eu utilizo hoje, eu tenho que reescrever essa parte do código em cada sub() (cada sub é um template de email), gostaria de saber se é possível eu escrever a assinatura fora em uma sub talvez, e só dar um call, quando chegar o momento de usar nos templates...

Segue abaixo como eu gostaria que ficasse, entretanto escrevendo a assinatura em outra sub, pra não deixar essa tão poluida, pois da forma que está eu acima desse código eu tenho também todo o código da assinatura = assinatura etc....
Código: Selecionar todos
sub exemplo

Texto = Texto & "<style>p{margin-top:0px; margin-bottom:0px;}</style><center><table width=""550"">"
Texto = Texto & "<p style=""font-weight: 400; text-align: justify;"">Prezados,</p>"
Texto = Texto & "<p style=""font-weight: 400; text-align: justify;"">Segue, em anexo</p>"
Texto = Texto & assinatura
Por osvaldomp
#61478
Diego100ges escreveu: 13 Jan 2021 às 14:21 ... gostaria de saber se é possível eu escrever a assinatura fora em uma sub talvez, e só dar um call, quando chegar o momento de usar nos templates...
Talvez seja possível utilizando o arquivo PERSONAL.xlsb. Vale a pena pesquisar.
Diego100ges agradeceu por isso
Por Raygsson
#61482
Pelo que entendi está muito fácil, faz uma Sub ou Funcition apenas pra carregar esse texto com o HTML, depois só chamar onde precisar, tipo:
Código: Selecionar todos
Sub TextoHTML(texto)
           Texto = Texto & "<style>p............."
           Texto = Texto & "<style>p............."
            Texto = Texto & "<style>p............."
End Sub

Sub email1 ()
       Call TextoHTML(texto)
       .......
       .......
       ......
End Sub

Sub email2 ()
       Call TextoHTML(texto)
       .......
       .......
       ......
End Sub

Sub email3 ()
       Call TextoHTML(texto)
       .......
       .......
       ......
End Sub

Diego100ges agradeceu por isso

Veja se atende. Selecione B4:G7 | menu Pág[…]

Ajuda sobre Formulario

mano valeu muito, deu certo coloquei em todos as l[…]

DataAtual + NºSérie

Entendi. Obrigado novamente pela explicaç&a[…]

@Angra , o botão para marcar resolvido[…]

Quero comparar as colunas sim, que neste caso s&[…]

Achei a dúvida bem interessa mas acho que o[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]