Tudo que estiver relacionado a tratamento de dados, Power Query editor e linguagem M
  • Avatar do usuário
#60820
Caros, boa noite!

Estou com um probleminha para resolver e preciso da ajuda dos nobres colegas.

Um cliente passou informações sobre eventos que ocorreram durante o ano de falta de energia de uma concessionária com datas e horários.
Preciso através do relacionamento destas datas e horas verificar se realmente existiram estes eventos citados, através de uma tabela do banco que registra todos os eventos em equipamentos supervisionados.

O problema é que os horários não são sincronizados com aqueles informados pelo cliente. Pensei em fazer algo de relacionar as informações de data e hora que o cliente informou com as datas e horas mais próximas registradas na tabela do banco e dentro de intervalo de 30 minutos antes e 30 minutos após da data e hora e informada pelo cliente.

Segue um exemplo da informação do cliente e da tabela existente no banco com os registros de eventos (dados fictícios):
Imagem
CoincidenciaAproximadaDataHora.xlsx
Você não está autorizado a ver ou baixar esse anexo.

Veja se atende. Selecione B4:G7 | menu Pág[…]

Ajuda sobre Formulario

mano valeu muito, deu certo coloquei em todos as l[…]

DataAtual + NºSérie

Entendi. Obrigado novamente pela explicaç&a[…]

@Angra , o botão para marcar resolvido[…]

Quero comparar as colunas sim, que neste caso s&[…]

Achei a dúvida bem interessa mas acho que o[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]