Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por pjuliocesar 23 Mai 2020 às 17:00
Membro Novato
Mensagens: 26
Reputação: 3
#55119
Olá,

Em anexo tenho uma planilha com 12 serviços, cada um deles com informações, sendo que uma coluna dessas é do VALOR do serviço e outro é do RECIBO.

Preciso de uma célula "TOTAL" que realize a soma da coluna "VALOR" de 1 a 12 quando RECIBO for igual a SIM!
Lembrando que essa equação se repetirá nas linhas 12,13,14 e assim por diante.

Por eu ser iniciante, usei a equação:

SOMASE((M12;S12;Y12;AE12;AK12;AQ12;AW12;BC12;BI12;BO12;AK12;AQ12;AW12;BC12;BI12;BO12;BU12;CA12);"SIM";(J12;P12;V12;AB12;AH12;AN12;AT12;AZ12;BF12;BL12;AH12;AN12;AT12;AZ12;BF12;BL12;BR12;BX12))

e obviamente deu erro. :roll:

Outra dúvida: Gostaria de saber se é possível criar intervalos intercalados "Como do exemplo" para que as equações entendam isso também.
Apenas usuários registrados podem ver ou baixar anexos.
Por babdallas 23 Mai 2020 às 17:44
Excel Expert
Mensagens: 2564
Reputação: 1128
#55122
Tente isso. A fórmula é matricial, portanto use Ctrl+Shift+Enter.

Código: Selecionar todos=SOMARPRODUTO(SEERRO(N(DESLOC($H12;;(COL($H$10:$CA$10)-COL($H$10))/(T(DESLOC($H12;;("RECIBO"=$H$10:$CA$10)*(COL($H$10:$CA$10)-COL($H$10))))="SIM")-3));0))
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 23 Mai 2020 às 17:58
Excel Expert
Mensagens: 1727
Reputação: 864
#55123
Experimente a fórmula matricial abaixo.

Código: Selecionar todos=SOMA(SE(M12:CA12="SIM";J12:BX12))


obs. por tratar-se de fórmula matricial, após colar a fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter e depois arraste pra baixo.
Por pjuliocesar 23 Mai 2020 às 18:54
Membro Novato
Mensagens: 26
Reputação: 3
#55129
Excelente!! Curto e direto! Deu certo. Muito obrigado