Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por osvaldocordeiro 08 Fev 2020 às 17:01
Membro 1 Estrela
Mensagens: 21
Reputação: 0
#52235
Boa tarde Osvaldomp,

Evoluí mais um pouco na fórmula.

=SEERRO(SES(LOCALIZAR("osvaldo";A1;1);"Jorge";LOCALIZAR("priscila";A1;1);"Rafael");"N/A")

OBS.: Se escrevo priscila na célula A1, eu tenho como resultado N/A e não Rafael.

Desde já obrigado.
Por osvaldomp 08 Fev 2020 às 18:27
Membro 5 Estrelas
Mensagens: 1591
Reputação: 786
#52236
Eu me proponho a tentar ajudar desde que você atenda ao que eu sugeri.
Por osvaldocordeiro 08 Fev 2020 às 19:58
Membro 1 Estrela
Mensagens: 21
Reputação: 0
#52242
Boa tarde Osvaldomp,

Na verdade é esta sintaxe da linguagem DAX (Power BI) abaixo que preciso transformar na fórmula do Excel. Veja:

if(FIND("COI"; SuperExtractExport[Program Name ]; 1; 0)>0; "COI";
if(FIND("Digital - Brazil Iron North Corridor"; SuperExtractExport[Portfolio ]; 1; 0)>0; "DT Brazil North";
if(FIND("Digital - Brazil Iron Southeast Corridor"; SuperExtractExport[Portfolio ]; 1; 0)>0; "DT Brazil Southeast";
if(FIND("Digital - Pelletizing"; SuperExtractExport[Portfolio ]; 1; 0)>0; "DT Pelletizing";
if(FIND("Digital - Canada"; SuperExtractExport[Portfolio ]; 1; 0)>0; "DT Canada";
if(FIND("Digital - Expansion"; SuperExtractExport[Portfolio ]; 1; 0)>0; "DT Expansion";
if(FIND("Workforce Effectiveness"; SuperExtractExport[Portfolio ]; 1; 0)>0; "Addit. Dig. Transformation";
if(FIND("RPA"; SuperExtractExport[Portfolio ]; 1; 0)>0; "Addit. Dig. Transformation";
if(FIND("AIC"; SuperExtractExport[Portfolio ]; 1; 0)>0; "Addit. Dig. Transformation";
if(FIND("Digital Transformation"; SuperExtractExport[Portfolio ]; 1; 0)>0; "Addit. Dig. Transformation";
"N/A"))))))))))

Desde já obrigado.
Por osvaldomp 09 Fev 2020 às 13:19
Membro 5 Estrelas
Mensagens: 1591
Reputação: 786
#52254
Veja se a solução aplicada no arquivo anexo atende.

Na planilha Tab Beneficios utilizei a fórmula abaixo em B2 e arrastei até B16.

Código: Selecionar todos=PROC(2;1/LOCALIZAR("*"&Sheet1!A$2:A$11&"*";A2);Sheet1!B$2:B$11)
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldocordeiro 11 Fev 2020 às 20:40
Membro 1 Estrela
Mensagens: 21
Reputação: 0
#52302
Boa noite Osvaldomp,

Muito obrigado pelo retorno!

Esta minha fórmula não poderia ser reaproveitada ao invés de usarmos duas planilhas?

=SEERRO(SES(LOCALIZAR("osvaldo";A1;1);"Jorge";LOCALIZAR("priscila";A1;1);"Rafael");"N/A")
Por osvaldomp 11 Fev 2020 às 21:02
Membro 5 Estrelas
Mensagens: 1591
Reputação: 786
#52303
1. quantidade de planilhas ~~~> você disponibilizou dois arquivos, aí eu montei a solução em um único arquivo com duas planilhas, mas se você quiser pode utilizar somente uma planilha, coloque os dados em uma só planilha e ajuste os endereços na fórmula que passei

2. sua fórmula ~~~> me parece que a sua fórmula ficaria exageradamente grande; ainda, se houver alguma alteração nos dados colocados na planilha seria necessário mexer na fórmula, ainda, a fórmula que passei é universal, funciona com base nos dados colocados na planilha, ao passo que a sua tem aplicação específica, ou seja, é válida somente para um determinado grupo de dados (os nomes inseridos na fórmula)
Por osvaldocordeiro 11 Fev 2020 às 21:32
Membro 1 Estrela
Mensagens: 21
Reputação: 0
#52304
A planilha original com os dados brutos possui 843 linhas. Mas, os valores a serem retornados são os mesmos.

Por gentileza, será que você conseguiria ajustar a minha para eu testar?
Por osvaldocordeiro 12 Fev 2020 às 20:46
Membro 1 Estrela
Mensagens: 21
Reputação: 0
#52322
Boa noite Osvaldomp,

Apliquei a fórmula que você forneceu na planilha. Segue planilha anexa.

Na linha 722, a fórmula retornou "Addit. Dig. Transformation" ao invés de "DT Brazil North", pois vem a cadeia de texto "Digital - Brazil Iron North Corridor" primeiro na célula.

OBS.: Peguei 3 exemplos. Nas linhas 722, 814 e 845.

Por gentileza, teria como fazer um ajuste na fórmula para retornar a primeira cadeia de texto que a fórmula encontrar da esquerda para a direita?

Desde já obrigado.
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 12 Fev 2020 às 22:07
Membro 5 Estrelas
Mensagens: 1591
Reputação: 786
#52323
A função utilizada na fórmula não permite esse ajuste.

No entanto, é possível resolver fazendo uma pequena mudança na ordem da tabela que está em D:E.
Assim, a expressão Digital Transformation que está em D11 passe-a para D3 (juntamente com E11 para E3) e mantenha a ordem das demais expressões.

Essa mudança aparentemente resolve os três casos que você citou acima.