Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por princessislost 13 Set 2019 às 03:15
Membro Novato
Mensagens: 4
Reputação: 0
#48142
Olá, meu primeiro post XD... estou estudando excel e não consegui pensar em nada mais legal do que estudar praticando... estou montando uma planilha de investimentos, aonde preciso fazer uma soma utilizando dois critérios o nome do ativo que é comparado a si próprio, e o outro critério é a data, que se encontra no formato "xx-xx-xxxx" e deve ser comparada com uma alfabética escrita por extenso, exemplo "01-01-2019" = "JANEIRO"....

Estou tendo dificuldades em utilizar a função SOMASES >>>
Código: Selecionar todos=somases(TABELA3[QUANTIDADE];MAIÚSCULA(TEXTO(TABELA3[DATA DE COMPRA];"mmmm"));J5


** J5 POSSUI O VALOR: AGOSTO


Obrigadinha :D
Por babdallas 13 Set 2019 às 05:34
Membro 5 Estrelas
Mensagens: 2010
Reputação: 887
#48143
Tente assim

Código: Selecionar todos=SOMARPRODUTO(TABELA3[QUANTIDADE]*(MAIÚSCULA(TEXTO(TABELA3[DATA DE COMPRA];"mmmm"))=J5))
Por princessislost 13 Set 2019 às 11:38
Membro Novato
Mensagens: 4
Reputação: 0
#48148
babdallas escreveu:Tente assim

Código: Selecionar todos=SOMARPRODUTO(TABELA3[QUANTIDADE]*(MAIÚSCULA(TEXTO(TABELA3[DATA DE COMPRA];"mmmm"))=J5))


Oi, obrigado pela ajuda... essa formula soma produto é valida para quando tenho mais de uma condição, no caso preciso pegar o nome do item da tabela comparar com uma célula e depois se TABELA3[QUANTIDADE]*(MAIÚSCULA(TEXTO(TABELA3[DATA DE COMPRA];"mmmm"))=J5 fazer a soma do intervalo, seria algo como:

Código: Selecionar todos=somases(
TABELA3[QUANTIDADE]; --- intervalo de soma das quantidades
MAIÚSCULA(TEXTO(TABELA3[DATA DE COMPRA];"mmmm"));J5; --- condição 1 a ser comprida
TABELA3[ATIVO];J4 --- condição 2 a ser comprida
)


Caso não tenha ficado claro eu reformulo