Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#68027
Boa tarde,

A empresa que trabalho tem um banco de dados que é atualizado diariamente e eu tenho uma planilha que puxa dados desse banco, a fórmula é a seguinte =PROCV(D3;'LINK DA PLANILHA ABAIXO'!$B$28:$G$224;6;0), o campo D3 é a data do dia anterior no caso de hoje (24/11) é a data de ontem (23/11), amanhã (25/11) será a data de hoje (24/11).
Imagem
A linha B28 é de onde eu quero começar a puxar os dados, porém quando o banco for atualizado amanhã (25/11) a linha B28 passará a ser a linha B29, quando atualizar no dia 26/11 ela passará a ser a B30 e assim por diante, eu preciso adaptar minha fórmula para acompanhar essa atualização diária sem ter que estar trocando manualmente todo dia, será que é possível algo desse tipo?
#68036
Uma solução simples seria usar INDIRETO().

=PROCV(D3;INDIRETO("'LINK DA PLANILHA ABAIXO'!$B$28:$G$224");6;0)

Isso evitaria q o intervalo fosse alterado, mas as últimas células q saíssem do intervalo não estariam mais acessíveis.
Nesse caso vc poderia adicionar =CORRESP(9^10;G:G;1) p/ identificar qual é a linha do intervalo.

=PROCV(D3;INDIRETO("'LINK DA PLANILHA ABAIXO'!$B$28:$G$"&CORRESP(9^10;G:G;1));6;0)

P/ outras soluções é muito importante q vc informe sua versão do Excel e ajuda se vc tb anexa sua planilha preservando a estrutura mas alterando os dados sensíveis.

Bom dia Para saber o número de linhas com V[…]

Olha só, sem vc anexar uma planilha exemplo[…]

Pessoal, gostaria de uma ajuda de vocês se p[…]

[AJUDA]VBA Crashando

up

Fórmula para contagem

Segue abaixo um exemplo

SOMAR PRODUTOS

Junqueira, desculpa a demora . obrigado. perfeito

Boa tarde. Com a ajuda de um membro do fór[…]