Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
#66155
Saudações, rezados.

Estou com dificuldade em criar um procv que encontre vários resultados repetidos e me mostre em uma única célula, é possível??

Ex. Eu digitar a Marca, e o resultado mostrar todos os modelos em um única célula
Imagem
#66160
Olá, @WeversonBorges .

Seguem duas ideias.

1. via função UNIRTEXTO() - versões 2019 ou 365 do Excel
Código: Selecionar todos
=UNIRTEXTO(", ";VERDADEIRO;SE(A3:A8=E3;B3:B8;""))
#

2. via UDF - funciona em qualquer versão e com qualquer quantidade de dados
Instale uma cópia da Function abaixo em um módulo comum, assim:
1. copie a Function daqui
2. a partir da planilha em que estão os dados tecle 'Alt+F11' para acessar o editor de VBA
3. no menu do editor / Inserir / Módulo
4. cole a Function na janela em branco que vai se abrir
5. feito! 'Alt+Q' para retornar para a planilha
6. em qualquer célula vazia digite ou cole ~~~> =ProcvMult()
Código: Selecionar todos
Function ProcvMult()
 Dim c As Range
  Application.Volatile True
  For Each c In Range("A3:A" & Cells(Rows.Count, 1).End(3).Row)
   If c.Value = [E3] Then ProcvMult = ProcvMult & ", " & c.Offset(, 1).Value
  Next c
  ProcvMult = Right(ProcvMult, Len(ProcvMult) - 2)
End Function
WeversonBorges agradeceu por isso
Exportação CSV

Quando faço a exportação de u[…]

Em C5: =SEERRO(SE(PROCV(B3;'Registro Pendencia'!A[…]

Macro Relatório Diário

Bom dia pessoal! Preciso de ajuda para elaborar um[…]

Olá, @brunoangelo . Sugestão, d[…]

Calculo horas power query

Boa noite, pessoal Tenho um problema que ainda n&[…]

RESOLVIDO!!!

Apresentações: fale sobre você!

começando agora a aprender VBA estou gostan[…]

Veja se o anexo ajuda Obs.: foi todo ajustado no p[…]