Tudo que estiver relacionado ao Excel básico, como somar, calcular média, colocar bordas, etc.
#65973
Pessoal, sou novo aqui no fórum, mas pelo que vi só tem feras no assunto.

É o seguinte, estou fazendo uma concatenação de modo a gerar uma inserção em uma tabela num banco de dados.

Eu criei a seguinte string (texto) com os campos que eu preciso enviar para o banco de dados.

="INSERT INTO NOME_TABELA (DS_MATERIA,NR_PAGINA,NR_EXERCICIO,RESPOSTA) VALUES('MATEMÁTICA',"&A3&","&C3&",'"&R2&"');"

Até aí tudo bem ele está preenchendo os campos conforme esperado, porém com um problema no último campo R2 que se trata de um campo do tipo FRAÇÃO. Quando o valor dele assume por ex.: 1/2, em vez do excel colocar '1/2' ele está substituindo o valor durante a concatenação da string colocando "0,5" em formato decimal, mas eu preciso que ele concatene o '1/2'.

Possivelmente deve ter algum comando pra eu colocar assim: String(R2), para transformar em string antes dele concatenar mudando o valor, mas eu não sei que comando eu poderia usar ali para impedir que ele troque o 1/2 por 0,5.

Alguém sabe como eu poderia resolver isso?

Desde já muito obrigado.  :) ;)
#65985
Olá, @wilsonfe .

Experimente ~~~> TEXTO(R2;"#0/#0")
#65988
Olá Osvaldo, muito obrigado pela ajuda!
Quase deu certo, acho que o formato é que eu preciso acertar agora, por exemplo, o valor 5 1/2 está sendo apresentado como 11/2. Como se trata do resultado de uma expressão, ele fica variando entre um número inteiro e fracionados, por exemplo, as vezes a resposta é 2, em outra conta é 2 1/3. Agora preciso entender como essas tratar essas duas condições de formato.

Valeu, muito obrigado!!
#65991
Veja se alguma destas abaixo funciona para todas as situações (números inteiros, frações simples e frações mistas).

=TEXTO(R2;"? ?/?")

=TEXTO(R2;"? ???/???")

Existe alguma forma de contornar essa situa&cced[…]

Jonathaluis, bom dia! Primeiramente quero agradec[…]

Boa noite, caso alguém puder me ajudar fic[…]

Obrigado, Jonatha. Imagino que a fórmula n&[…]

Boa tarde, pessoal. Precisando de ajuda ou sugest[…]

Boas pessoal! Sou novo por aqui e tenho conhecimen[…]

@Vilmar estou usando a medida abaixo Valor Ul[…]

Recursos humanos

Tente: Media Salarial = CALCULATE ( AVERAGE ( Ta[…]