Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por Wagner201
#65250
Tenho uma planilha onde possuo informações de nome e pontuação. Consigo fazer um ranking usando o Procv com as maiores notas, usando em uma coluna a função MAIOR e em outra a PROCV para o nome correspondente. Até aí dá certo. Mas eu quero fazer DOIS RANKINGS na mesma planilha, usando os mesmos nomes, mas com uma coluna numérica diferente. Sempre dá erro.
Avatar do usuário
Por Deciog
#65255
Wagner201, Boa Tarde.

Poste um modelo para que possamos fazer a formula e testar e também qual é a versão do seu Excel

Para anexar, vá em + resposta, adicionar anexo.

Decio
Avatar do usuário
Por Wagner201
#65256
Obrigado pelo retorno;

Segue o modelo da planilha simplificada e onde parei na tentativa e as fórmulas já inseridas.

Bom dia a todos.
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#65268
Experimente uma cópia da fórmula abaixo em L2 e arraste para baixo.
Código: Selecionar todos
=SEERRO(ÍNDICE($B$5:$B$32; CORRESP(0; SE(M2=F$5:F$32; CONT.SE(L$1:L1; $B$5:$B$32); ""); 0));"")
Avatar do usuário
Por Wagner201
#65278
Obrigado, Osvaldo, pela ajuda, mas apesar de não dar erro, os nomes correspondentes não aparecem nas células.
Por osvaldomp
#65279
Veja o print abaixo e o arquivo anexo com a fórmula que passei.
#
Imagem
Você não está autorizado a ver ou baixar esse anexo.
Wagner201 agradeceu por isso
Avatar do usuário
Por Wagner201
#65326
Prezado Osvaldo. Esta dica foi ótima. Agradeço mais uma vez.

Mas observe o erro que fica dando na planilha onde estou aplicando esta operação. Ela possui várias diferenças, mas fiz as alterações correspondentes às posições de linhas e colunas. Estou enviando o trabalho final para você o pessoal identificarem a falha lógica. Não consegui identificar.
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#65328
Wagner201 escreveu: 23 Jun 2021 às 08:05 ... mas fiz as alterações correspondentes às posições de linhas e colunas.
Uma das alterações que você fez está incorreta. Veja abaixo.
corrija
de ~~~> CONT.SE($M$16:M16;
para ~~~> CONT.SE($M$15:M15;
Wagner201 agradeceu por isso
Avatar do usuário
Por Wagner201
#65349
Fiz a alteração, mas não sei o que ocorre. O erro é o mesmo. Os números correspondentes à coluna certa aparecem, mas os nomes, não.

Segue a versão com a correção que me pediu. Veja. Não sei onde está a falha.
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#65350
Amigão, esta é a última ajuda.

Verifique se este trecho está de acordo com a fórmula que passei ~~~> SE(M15=F$5:F$32
Avatar do usuário
Por Wagner201
#65361
Obrigado pela ajuda até aqui. Já caminhei bastante e reconheço sua contribuição.

Fique em paz e sucesso na vida. Vou encontrar a solução.

Abraço.

Tudo beleza pessoal? Estou com uma dúvida […]

Como limpar o meu código

Você é genio... Muito obrigado, muito[…]

Veja se alguma destas abaixo funciona para todas a[…]

Excel 365

Prezados, estou tendo problemas com algumas planil[…]

Bom dia. Conforme solicitado. Até Foxtri

Foxtri Grato pelo apoio, assim como o companheiro […]

Qual é o erro retornado ? Se for 91 - A […]

PERFEITO, MUITO OBRIGADO