Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por Jerys
#65145
OLÁ AMIGOS

Estou com problema em uma tabela para conferencia de jogos, preciso adicionar a dezena 00 quando alguém joga, pois quando coloco o 00 nas contagem de acertos ele acaba dando erro e somando toda conferencia como acerto. Segue em anexo .obrigado
Editado pela última vez por Jerys em 13 Jun 2021 às 20:51, em um total de 1 vez.
Por osvaldomp
#65146
No final da fórmula que está em C3 substitua o zero por "-" (sinal de menos entre aspas duplas)
Jerys agradeceu por isso
Avatar do usuário
Por Jerys
#65147
obrigado osvaldo ...quase deu certo rsrsr .... fazendo dessa maneira ainda vai marcar 1 ponto pq um unico zero é exclusivo .
Por osvaldomp
#65149
Entendi. :)

Veja se assim resolve: desfaça a alteração que passei antes, ou seja, coloque o zero de volta no lugar do "-" e troque a fórmula que está em L6 por essa abaixo que não conta os zeros.
=SOMARPRODUTO(CONT.SE(B6:K6;Planilha2!C$3:C$152)*(Planilha2!C$3:C$152>0)) ~~~> não é necessário inseri-la como matricial pois SOMARPRODUTO() já é matricial nativa.
Jerys agradeceu por isso
Avatar do usuário
Por Jerys
#65150
Osvaldo...agora ele parou de contar o zero , só que quando eu coloco nos números sorteados o 00 (dezena ) teria que aparecer nos exclusivos e contabilizar nessa formula que me passou. Mas ai ele não conta nem o 00 mais .. deu pra entender minha explicação, desculpa algo e obrigado

Osvaldo teria como estrar remoto cmg? Para tentar finalizar isso?
Avatar do usuário
Por Deciog
#65152
Jerys, Bom Dia.

Tenta essa formula é matricial

=SOMA(SINAL(CONT.SE(B6:K6;SE(Planilha2!C$3:C$152>0;Planilha2!C$3:C$152))))+SOMA(SE($B$6:$K$6=0;1;0))

Caso não está correto, preencher as outras informações para que posso testar as formulas

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Jerys agradeceu por isso
Por osvaldomp
#65155
Salve, @Jerys .

Segue uma solução mais simples pois faz a contagem direta dos acertos (não utiliza a tabela existente na Planilha2).

Cole uma cópia da fórmula abaixo em L6 da Planilha1 e aplique duplo clique no canto direito inferior daquela célula para estender a fórmula pela coluna.
Código: Selecionar todos
=SE(CONT.VALORES(B6:K6)<10;0;SOMA(SE(CONT.SE(RESULTADO;B6:K6)>=1;1)))
obs. enquanto as 10 dezenas de cada jogo não forem preenchidas a fórmula retornará zero, porém se você preferir que retorne vazio então substitua na fórmula o zero por "" (duas aspas duplas).

dica - a Formatação Condicional existente em B6:K50, cuja finalidade é pintar as dezenas acertadas, pinta também células vazias, para evitar altere as fórmulas, por exemplo,
altere de =CONT.SE($B$81:$F$85;B6)>0 ~~~> para ~~~> =E(B6<>"";CONT.SE($B$81:$F$85;B6))
obs. na Formatação Condicional não é necessário o comparativo >0 na função CONT.SE(), pois como a FC atua se o resultado da fórmula for VERDADEIRO e o Excel entende que se a contagem for zero então o resultado é FALSO, e se for maior do que zero é VERDADEIRO, esse recurso dispensa o comparativo. ;)
Jerys agradeceu por isso
Avatar do usuário
Por Jerys
#65159
Salve professor ...rapaz deu certo demais ficou lindo ...e ainda simplificou toda a planilha kkkk ....bati tanto cabeça pra chegar naquilo e no final nem precisava rsrsrsr

osvaldo vou mandar ela novamente corrigida ....preciso tirar o erro que apareceu agora nas duas colunas na ultima folha lá embaixo RESULTADO FINAL
Editado pela última vez por Jerys em 13 Jun 2021 às 20:51, em um total de 1 vez.
Por osvaldomp
#65161
O erro é originado na fórmula da coluna M. Por exemplo, em M95 a fórmula busca a sexta maior pontuação, porém só há cinco pontuações (cinco nomes/jogos/acertos),
por isso a fórmula retorna erro que afeta as fórmulas em B95 e H95.

Para contornar coloque um tratamento de erro em M90 ~~~> =SEERRO(MAIOR($M$6:$M$50;A90);"")
Assim, o erro será eliminado também em B e em H. As fórmulas em H passarão a exibir vazio e as fórmulas em B exibirão zero, e se você quiser exibir vazio
também em B, coloque em B90 ~~~> =SE(M90="";"";ÍNDICE($A$6:$A$50;CORRESP(M90;$M$6:$M$50;0)))
#
dica - evite mesclar células, pois células mescladas podem provocar erros em fórmulas e ou em macros; há outro caminho para conseguir um efeito visual equivalente à mesclagem, porém sem causar possíveis problemas. Por exemplo no caso das células mescladas B90:M90: selecione B90 | desfaça a mesclagem | selecione B90:M90 | clique com o direito | Formatar Células | Alinhamento | Horizontal | Centralizar seleção | OK.
Para estender essa formatação para baixo clique na ferramenta Pincel e selecione B91:B134. As fórmulas lá existentes não serão afetadas.

Idem em H90:I90.
Jerys agradeceu por isso
Avatar do usuário
Por Jerys
#65164
Bingo kkk... muito obrigado pela ajuda ...ficou 1000% ,fiz tudo isso da maneira que me passou... obrigado pela atenção amigo vc é fera.
osvaldomp agradeceu por isso
Como limpar o meu código

Você é genio... Muito obrigado, muito[…]

Veja se alguma destas abaixo funciona para todas a[…]

Excel 365

Prezados, estou tendo problemas com algumas planil[…]

Bom dia. Conforme solicitado. Até Foxtri

Foxtri Grato pelo apoio, assim como o companheiro […]

Qual é o erro retornado ? Se for 91 - A […]

PERFEITO, MUITO OBRIGADO

Bom dia. Talvez desta forma ?? =SOMA(SE(FREQÜ[…]