Tópicos relacionados a códigos VBA, gravação de macros, etc.
Por CAMILOALVES
#65084
Bom Dia
Na Planilha “Inserir Pendencia PR” contém um botão “INSERIR” que possui uma rotina (macro) que deveria estar copiando as fórmulas das células “Q7” e “S7” para colunas 17 (Pendente?) e 19 (ano_AUX) respectivamente para a planilha “Registro Pendencia PR” sempre que houver uma nova inclusão de dados através da planilha “Inserir Pendencia PR” .
Peço ajuda na análise, pois a referida rotina (macro) não dá mensagem de erro, simplesmente não copia as fórmulas para linha posteriores.
Desde já agradeço
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#65092
Salve, @CAMILOALVES .

Me parece que você quer copiar as fórmulas de Q7 e S7 da planilha Registro e colar na última linha da própria planilha, que foi recém preenchida pelo código. É isso?

A propósito, na fórmula em Q7 ~~~> =SE(B7="";"";SE(E(L7="";M7="";N7="");"SIM";SE(OU(L7<>"";M7<>"";N7<>"");"NÃO"))) o último SE é desnecessário,
então pode ser simplificada para ~~~> =SE(B7="";"";SE(E(L7="";M7="";N7="");"SIM";"NÃO"))

Ainda, confirme pois ao final o seu código chama este outro CopiaColaFórmulasPR que aparentemente não tem utilidade nessa situação.
CAMILOALVES agradeceu por isso
Por CAMILOALVES
#65094
Prezado osvaldomp - 10 Jun 2021 às 15:15, Boa tarde!
Grato por dispor seu tempo para me orientar e ajudar.
Então..
A ideia é essa mesmo, copiar as fórmulas das células "Q7" e "S7" até a última linha preenchida, por isso a rotina: Call CopiaColaFórmulasPR está agregada na macro, porém a referida macro (CopiaColaFórmulasPR) não está atendendo ao proposto, sendo assim, se possível, peço analisar o que há de errado com ela (CopiaColaFórmulasPR) .
Desde já agradeço
OBS: Já fiz a simplificação da fórmula da célula "Q7" conforme sugerido por Você.
Abraços
Por osvaldomp
#65124
CAMILOALVES escreveu: 10 Jun 2021 às 14:47 ... porém a referida macro (CopiaColaFórmulasPR) não está atendendo ao proposto, sendo assim, se possível, peço analisar o que há de errado com ela ...
Nada de errado com ela, o erro é tentar aproveitá-la, pois como comentei antes, ela não pertence a este jogo.
Instale uma cópia do código baixo no lugar do existente. Ele replica os dados, as fórmulas e limpa os dados de origem.
Código: Selecionar todos
Sub lsIncluirNCPR()
 Dim k As Long, c As Range, LR As Long
  LR = Sheets("Registro Pendencia PR").Cells(Rows.Count, 1).End(3).Row + 1
  For Each c In Range("C9:C13,D13,C14,C16:C17,C15,C18,W1:Y1,C19:C20")
   Sheets("Registro Pendencia PR").Cells(LR, k + 1) = c.Value: k = k + 1
  Next c
  Sheets("Registro Pendencia PR").[Q7].Copy Sheets("Registro Pendencia PR").Cells(LR, 17)
  Sheets("Registro Pendencia PR").[S7].Copy Sheets("Registro Pendencia PR").Cells(LR, 19)
  [C10:C18] = ""
End Sub
CAMILOALVES agradeceu por isso
Por CAMILOALVES
#65130
Prezado osvaldomp - 11 Jun 2021 às 15:00, Boa Tarde!
Bingo!
Obrigado por dedicar seu tempo para ajudar-me.
Meu respeito e minha admiração.
DEUS continue lhe dando sabedoria.
Atenciosamente.
osvaldomp agradeceu por isso
Por osvaldomp
#65137
Salve, @CAMILOALVES .

Que bom que você resolveu a sua demanda. :)

God bless you too! ;)
CAMILOALVES agradeceu por isso
Ranking PROCV

... mas fiz as alterações correspo[…]

Bom dia comunidade! Preciso implementar uma solu&[…]

Pessoal Boa noite. Tenho uma planilha, que escrev[…]

Saldos

Olá, estou fazendo um dashboard e tenho um[…]

Deve ter outra forma, mas sugiro que faça n[…]

Tente esta: Acc = CALCULATE ( [Receita], […]

AJUDA COM FUNÇÃO "SE"

O problema não é devido ao uso da fu[…]

Veja no link abaixo se aproveita algo. https://w[…]