Assuntos relacionados a criação de medidas, fórmulas e funções DAX, relacionamentos etc
Por Weflly
#63547
Estou criando um ranking de corretores aqui no meu trabalho para premiação das maiores vendas.
Fiz um top 10 que quando clica no número aparece os corretores e gerentes do ranking escolhido. Exemplo: Clico no TOP 5 e aparece os 5 corretores e os 5 gerentes com mais vendas.
No entanto tem uma pessoa que aparece como corretor e como gerente porque fez algumas vendas, e essa pessoa é dona de uma das imobiliárias e não vai ganhar prêmio por isso. Como faço para esse cara sumir sem ter que exclui-lo dos dados?
Excluindo ele direto no gráfico o TOP fica com uma pessoa a menos. Ex: Top 5 fica com 4 pessoas.
Por babdallas
#63589
Medida da soma de vendas
Código: Selecionar todos
Vendas=SUM(fVendas[Valor])
Medida para o ranking
Código: Selecionar todos
RANKING=RANKX(FILTER(ALL(fVendas);fVendas[NOME]<>"Nome Presidente");[Vendas])

Medida para ter o TOP 5 Vendas
Código: Selecionar todos
TOP5_MenosPresidente=VAR TabelaSemPresidente = TOPN(5;FILTER(fVendas;fVendas[NOME]<>"Nome Presidente");[Vendas];DESC)
RETURN
	IF([RANKING]<=5;CALCULATE([Vendas];TabelaSemPresidente);BLANK())
Weflly agradeceu por isso

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]