Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
#63577
Bom dia, pessoal.

Escrevi uma fórmula matricial na Coluna [Qtde Posição Aberta] que me retorna a quantidade restante de um Ativo.

Preciso ajustar ela para que mostre a quantidade apenas nas linhas em que não houver Posição Encerrada.

Isso serve para que eu possa calcular o preço médio atual do Ativo, desconsiderando as posições que já foram encerradas

Considerando o Ativo GOAU como exemplo da planilha anexa:
- Reparem que na linha de Registro 4 tenho a compra de 100 Ativos GOAU4
- Na linha de Registro 6 tenho a venda de 100 Ativos GOAU4
- Nesse caso a posição foi encerrada e a Coluna [Qtde Posição Aberta] deve retornar "-" nas linhas 4 e 6.

Agora reparem que:
- Na linha de Registro 12 tenho a venda de 200 Ativos GOAU4
- Na linha de Registro 14 tenho a Compra de 100 Ativos GOAU4
- Na linha de Registro 16 tenho a Compra de 50 Ativos GOAU4
- Nesse caso a posição ainda encontra-se aberta com o resultado de -50 (posicionado na venda em 50 Ações do Ativo) que deve aparecer na Coluna [Qtde Posição Aberta] SOMENTE enquanto a posição não estiver encerrada.

Coloquei uma Coluna com o Resultado Desejado inserido manualmente.

Podem me ajudar com isso?

Segue planilha anexa para melhor entendimento e realização de testes.
Você não está autorizado a ver ou baixar esse anexo.
#63588
Progredi um pouco no desenvolvimento da fórmula mas ainda não cheguei no resultado desejado. Foi só uma ideia de como fazer.

Se alguém tiver outra ideia de como fazer peço ajuda.

Segue planilha com a Coluna {Teste - Nova Fórmula] e a Coluna (Resultado Desejado].

Destaquei na cor laranja onde não estou conseguindo reproduzir o resultado desejado.
Você não está autorizado a ver ou baixar esse anexo.

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]