Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Por bhashizumi
#63537
Boa tarde pessoal!
Fiz um PROCV na planilha abaixo para buscar o valor do ativo na semana anterior. Quando eu uso o resultado para fazer qualquer conta ele me volta "#valor" como na celula k298 na imagem.
Alguém pode me ajudar por favor?
Imagem
Por babdallas
#63543
Anexa uma planilha Excel como exemplo, por favor.
Avatar do usuário
Por Estevaoba
#63556
Sem um modelo da sua planilha para testar fórmulas fica difícil, mas não creio que essa fórmula funcione corretamente, pois ela busca valores concatenados de duas colunas (B & D) em uma única coluna (A). Eu usaria desta outra forma:
Código: Selecionar todos
=ÍNDICE(F:F;CORRESP(B298-7&D298;A:A&D:D;0))
Fórmula matricial. Se o seu Excel for anterior ao 365, confirme com Ctrl+Shift+Enter em vez de apenas Enter.

Good luck!
bhashizumi agradeceu por isso
Por bhashizumi
#63587
Foi mal.. Nem pensei em adicionar o anexo.. Vou mandar aqui..
A Formula matricial também não deu certo!
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#63595
bhashizumi escreveu: 07 Abr 2021 às 13:55 ... qualquer conta ele me volta "#valor" como na celula k298 na imagem.
Em K298:
Código: Selecionar todos
=SUBSTITUIR(SUBSTITUIR(J298;",";"");".";",")-SUBSTITUIR(SUBSTITUIR(F298;",";"");".";",")
bhashizumi agradeceu por isso
Avatar do usuário
Por Deciog
#63600
bhashizumi, Bom Dia.

No seu exemplo com valores expressos em Inglês, eu usaria desta forma na célula K298

Para a versão Excel antes de 2019, feche com CTRL + SHIFT + ENTER, são formula matricial

=INT(VPL(-0,9;SEERRO(EXT.TEXTO(J298;1+NÚM.CARACT(J298)-LIN(INDIRETO("1:"&NÚM.CARACT(J298)));1)/10;"")))/100-INT(VPL(-0,9;SEERRO(EXT.TEXTO(F298;1+NÚM.CARACT(F298)-LIN(INDIRETO("1:"&NÚM.CARACT(F298)));1)/10;"")))/100

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Ajuda sobre Codigo

Galera precisava de uma ajuda vi um vídeo n[…]

o problema está no fato de vc ter agrupamen[…]

Botão delete

Obrigado pela ajuda (y) :) Saudaçõe[…]

Formatação para impressão de etiquetas

é bem chatinho isso pois os dados nessa col[…]

Contagem de dados repetidos

Seguem 2 opções. eu queria ente[…]

procurar e inserir linhas

se eu entendi bem, vc quer uma macro que te arrume[…]

Atualizar Fonte de Dados da Tabela Dinâmica

fico contente que tenha dado certo. Não do[…]

não sei se já resolveu, mas as linha[…]