Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por Jotapecast
#62628
Boa tarde a todos,

Preciso de ajuda na função PROCV, em relação aos argumentos que posso utilizar, visto que pretendo utilizar mas o Excel não permite, apresentando a mensagem: "Introduziu número excessivo argumentos para esta função".

A fórmula que tenho:

=SE.ERRO(SE([@Serviço]=auxiliares!L$2;PROCV([@Diâmetro]&[@Unidade];auxiliares!$E:$H;4;0);PROCV([@Diâmetro]&[@Unidade];auxiliares!$E:$I;5;0));"---")

e pretendo acrescentar mais duas vezes: PROCV([@Diâmetro]&[@Unidade];auxiliares!$E:$J;6;0);PROCV([@Diâmetro]&[@Unidade];auxiliares!$E:$K;7;0) mas o Excel não permite.

"auxiliares" é a folha onde ele vai buscar os dados, e eu pretendo que vá buscar os dados a 4 colunas (Coluna H; Coluna I; Coluna J; Coluna K, mas ele só está a buscar a 2 colunas,
Imagem

e na coluna K da folha B.Dados quando escolher o tipo de serviço, pretendo que dê o valor respetivo.
Imagem

Agradeço desde já a ajuda!
Avatar do usuário
Por AfonsoMira
#62630
Boas,
Para podermos ajudar melhor, por favor anexe o seu arquivo e não imagem do mesmo, para podermos testar as fórmulas.
Obrigado!
Avatar do usuário
Por Jotapecast
#62633
Boa tarde,

Agradeço antes de mais a resposta.

Segue em anexo ficheiro com as fórmulas.

Aguardo ajuda se possível na resolução desta questão.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por AfonsoMira
#62637
Veja se é isto que pretende:
Você não está autorizado a ver ou baixar esse anexo.
Jotapecast agradeceu por isso
Avatar do usuário
Por Jotapecast
#62638
É isto mesmo!! :D

Nunca mais ia conseguir resolver, estava a insistir sempre na mesma função, e afinal tinha de ser outra fórmula.

Agradeço-lhe imenso pela ajuda!
Avatar do usuário
Por AfonsoMira
#62639
Foi um prazer ajudar! :D
Jotapecast agradeceu por isso
Avatar do usuário
Por AfonsoMira
#62642
A opção encontra-se desativada por enquanto, experimente editar o título do Tópico acrescentando "RESOLVIDO"

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]