Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
#62377
Olá, estou a fazer um trabalho sobre inspeção por amostragem.
Há uma condição que diz: se dos últimos 5 lotes, 2 forem rejeitados, a inspeção deve passar para inspeção apertada.
Se fosse só um tipo de peça, selecionava as últimas 5 células... mas o problema é que tenho que fazer inspeções
a vários tipos peças diferentes (A, B, C...). e eu não consigo encontrar nenhuma combinação de formulas que funcione.
Alguém me pode ajudar?
Aqui está o exemplo
A B C
1 Peça Estado AVISO
2 A ACEITE OK
3 A ACEITE OK
4 A REJEITADO OK
5 B ACEITE OK
6 B ACEITE OK
7 A REJETADO PASSAR PARA INS.APERTADA
8 B ACEITE OK
9 A ACEITE OK
10 A ACEITE OK
#62397
#
Experimente:
Código: Selecionar todos
=SE(CONT.VALORES(B2:C2)<2;"";SE(CONT.SE(B$2:B2;B2)<5;"OK";SE(CONT.SES(DESLOC(C2;;;-LIN()-1+MAIOR(SE(B$2:B2=B2;LIN(C$2:C2));5));"REJEITADO";DESLOC(B2;;;-LIN()-1+MAIOR(SE(B$2:B2=B2;LIN(C$2:C2));5));B2)>1;"INSP. APERTADA";"OK")))
#
1. na próxima vez disponibilize uma amostra do arquivo Excel com alguns dados e com o resultado esperado.
2. no seu exemplo o resultado na linha 7 está incorreto, pois até aquela linha há 4 peças do tipo A e não 5, como está no seu critério.
vaniasofiabs agradeceu por isso
#62580
Olá @osvaldomp
Apareceu-me outro problema. Agora preciso de somar o total dos últimos 10 defeitos (n defeitos) para um determinado o produto mas com a condição dos últimos 10 lotes serem aceites. Achas que consegues ajudar?
Obrigada!
Você não está autorizado a ver ou baixar esse anexo.
#62592
Experimente:
Código: Selecionar todos
=SE(CONT.VALORES(A2;D2;E2)<3;"OK";SE(CONT.SE(A$2:A2;A2)<10;"OK";SOMASES(DESLOC(D2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;LIN(C$2:C2));10));DESLOC(E2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;LIN(C$2:C2));10));"Aceite";DESLOC(A2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;LIN(C$2:C2));10));"A")))
#62615
Olá @osvaldomp
A formula está quase perfeita, esqueci-me de dizer que é necessário que os 10 lotes "aceites" devem ser consecutivos para um determinado produto.
Mando um ficheiro exemplo.
Obrigada!
Você não está autorizado a ver ou baixar esse anexo.
#62647
Experimente:
Código: Selecionar todos
=SE(OU(CONT.VALORES(A2;D2;E2)<3;CONT.SES(A$2:A2;A2;E$2:E2;"Aceite")<10);"OK";SE(CONT.SES(DESLOC(A2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;SE(E$2:E2="Aceite";LIN(C$2:C2)));10));A2;DESLOC(E2;;;-LIN()-1+MAIOR(SE(A$2:A2="A";SE(E$2:E2="Aceite";LIN(C$2:C2)));10));"<>Aceite")<1;SOMASES(DESLOC(D2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;SE(E$2:E2="Aceite";LIN(C$2:C2)));10));DESLOC(E2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;SE(E$2:E2="Aceite";LIN(C$2:C2)));10));"Aceite";DESLOC(A2;;;-LIN()-1+MAIOR(SE(A$2:A2=A2;SE(E$2:E2="Aceite";LIN(C$2:C2)));10));A2);"OK"))

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]

Boa tarde!! Tenho uma planilha para calculo de ho[…]

Veja se atende agora.

Opa, Vilmar, bom dia. Vou anexar um novo arquivo. […]

Botão delete

Caro pedcoi você precisa ir no Visual Basic […]

Boa tarde, pessoal. Preciso de ajuda com uma F&oa[…]

JCabral, boa tarde! Segue anexo o exemplo. Como f[…]