Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#62256
Olá. Gostaria da ajuda de vocês para resolver um problema de programação.
A tabela abaixo é de uma planilha alimentada por um formulário do Google Docs.

Local | Data | Produto 1 | Produto 2 | Produto 3
A | 09/02/21 | R$ 23,50 | R$ 7,08 | R$ 24,00
B | 09/02/21 | R$ 26,00 | R$ 7,09 | R$ 24,50
A | 10/02/21| R$ 23,50 | R$ 7,08 | R$ 24,00
B | 10/02/21 | R$ 24,00 | R$ 7,09 | R$ 24,50

Em uma outra planilha eu estou construindo uma tabela de resultado para filtrar estas informações, como exposto abaixo.

| Local A | Local B
Produto 1 | X | X1
Produto 2 | Y | Y1
Produto 3 | Z | Z1

Sendo assim, na célula B2, cujo resultado é "X" eu preciso retornar o valor do “Produto 1” para o “local A” referente à última data preenchida e assim sucessivamente para os demais produtos e locais.

Poderiam me ajudar indicando qual fórmula utilizar para fazer esta programação?
#62297
Fórmula matricial. Cole em B2 e confirme com Ctrl+Shift+Enter.
Copie para a direita e para baixo:
Código: Selecionar todos
=ÍNDICE(ENTRADA!$C$2:$E$7;MÍNIMO(SE(ENTRADA!$B$2:$B$7=MÁXIMO(SE(ENTRADA!$A$2:$A$7=DIREITA(B$1;1);ENTRADA!$B$2:$B$7));SE(ENTRADA!$A$2:$A$7=DIREITA(B$1;1);LIN(ENTRADA!$A$2:$A$7)-LIN($A$2)+1)));CORRESP($A2;ENTRADA!$C$1:$E$1;0))
Na sua planilha real, suponho que os locais serão os mesmos na coluna A da aba Entrada e na linha 1 da aba resultado (sem a palavra Local).
Nesse caso, substitua o argumento =DIREITA(B$1;1) por =B$1

Good luck!
BrunoM agradeceu por isso
#62313
Obrigado @Estevaoba pelo resposta.

Refiz os procedimentos e sua fórmula funciona! Muito obrigado.

No entanto, eu gostaria de uma outra dúvida.

Como posso adaptar esta fórmula para quando o valor de um produto não for preenchido, ou seja, não há registro de um valor para um determinado produto em um local em uma determinada data. Quando isto ocorrer, eu queria que resultado que retornar-se fosse o valor referente a última data coletada para este produto neste local, os quais tenha os dados inseridos, ou seja, fosse diferente de "zero" ou "vazio". Conforme a OBS na Planilha RESULTADO no link a seguir.

https://docs.google.com/spreadsheets/d/ ... sp=sharing

Agradeço a sua ajuda.
#62378
Obrigado @Foxtri

Sua equação funciona perfeitamente bem.

Poderia me explicar rapidamente o que significa XLoc e QualColuna nesta equação? Como eles buscam os números na planilha ENTRADA sem ser referido na equação?

Pois quando eu colo a tua equação na planilha do google abaixo, ela não lê.

https://docs.google.com/spreadsheets/d/ ... =444451694

Agradeço sua ajuda.
Procurar valor em um texto

=ESQUERDA(V2;LOCALIZAR(",";V2)-1) Conseg[…]

cont.se com ext.texto

Bom dia, Estou tentando unir as fórmula[…]

Ventura , Bom dia. Obrigado pelo feedback. Fico[…]

thaisdoo , Bom dia. Obrigado pelo feedback. Fic[…]

Você não esta conseguindo porque os […]

Ajuda com botões em linhas.

Veja se esta solução ajuda. Funcion[…]

Segue uma ideia. Aplique Formataçã[…]

Boa tarde, AfonsoMira. Funciona sim... Muito obri[…]