Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por brunocunha
#61789
Tenho uma planilha porem as vezes vai ser necessário mesclar algumas células da coluna B, só que como ela está protegida para não apagarem ou modificarem algumas formulas não aparece essa função de mesclar, teria como mesclar deixando ela protegida ? Ou teria como proteger apenas uma parte da planilha e outra deixar liberado para poder mesclar ?
#61790
Olá isto apenas é possível através de Macro/VBA.

Código:
Código: Selecionar todos
Sub mesclar()
Application.ScreenUpdating = False
ActiveSheet.Unprotect '"Palavra-Chave"
Selection.Merge
ActiveSheet.Protect '"Palavra-Chave"
Application.ScreenUpdating = True
End Sub
Selecione as células que deseja mesclar e corra o código.
#61791
o problema que quem vai preencher são operadores da linha de produção da fábrica aí eles não tem esse conhecimento, precisaria fazer algo mais simples sem precisar digitar a vba toda vez que fosse mesclar
#61794
Pode utilizar um botão para correr o código.
Consegue disponibilizar o seu ficheiro que eu lhe implemento isso ? :)
#61799
Veja se assim dá:
Você não está autorizado a ver ou baixar esse anexo.

Veja se atende. Selecione B4:G7 | menu Pág[…]

Ajuda sobre Formulario

mano valeu muito, deu certo coloquei em todos as l[…]

DataAtual + NºSérie

Entendi. Obrigado novamente pela explicaç&a[…]

@Angra , o botão para marcar resolvido[…]

Quero comparar as colunas sim, que neste caso s&[…]

Achei a dúvida bem interessa mas acho que o[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]