Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#61581
Boa noite, estou criando uma planilha para conferir algumas coisas, e me deparei com a seguinte dificuldade, preciso que alguma formula compare o conteúdo das células de varias colunas, e me retorne todos os nomes que apareceram na mesma.

Exemplo:

Imagem

Onde os dias seriam preenchidos no final a formula mostraria na coluna Semana, todos os nomes que apareceram nas outras colunas

ps. Faltou o "~" no primeiro joão, mas foi só um exemplo que fiz para demonstrar a minha duvida, ignorem por favor
#61590
Estevaoba escreveu:Fórmula matricial, cole em D2 e confirme com Ctrl+Shift+Enter em vez de apenas Enter:
Código: Selecionar todos
=SEERRO(INDIRETO(TEXTO(MÍNIMO(SE(($A$2:$C$4<>"")*(CONT.SE($D$1:D1;$A$2:$C$4)=0);LIN(Z$2:Z$4)*100+COL($A1:$C1)));"L0C00"););"")
Copie para baixo.

Good luck!
Amigo, testei da forma como mandou porem ficou em branco, anexei aqui o exemplo exato que tinha feito, juntamente com o exemplo mais parecido com o qual vou utilizar. caso você possa ajudar...
teste.xlsx
Você não está autorizado a ver ou baixar esse anexo.
#61591
Na sua planilha a fórmula está com @ antes dos intervalos.
Cole a fórmula como está no meu primeiro post, ou se preferir, use esta:
Código: Selecionar todos
=SEERRO(INDIRETO(TEXTO(MÍNIMO(SE(($A$2:$C$4<>"")*(CONT.SE($D$1:D1;$A$2:$C$4)=0);LIN(Z$2:Z$4)*100+COL($A1:$C1)));"L0C00");0);"")
E se o seu Excel for anterior à versão 2019, use Ctrl+Shift+Enter.

Ab.
Lord agradeceu por isso
#61598
Amigo, funcionou, após usar o Ctrl+Shift+Enter, mesmo estando na versão 2019, Mas ao tentar aplicar na minha planilha, ele repete o mesmo nome, tem algum limite de linhas/colunas para utilizar esta formula?

Eu estou tentando utilizar de A ~ G Conferencia na linha H com até 100 linhas de A ~ G, e deixando 120 linhas na H (não haverá variação de mais de 20 nomes)

e alterei o formula da seguinte forma:
Código: Selecionar todos
=SEERRO(INDIRETO(TEXTO(MÍNIMO(SE(($A$2:$G$102<>"")*(CONT.SE($H$1:H1;$A$2:$G$102)=0);LIN(Z$2:Z$102)*100+COL($A1:$G1)));"L0C00");0);"")
Converter número em letra

Bom dia. Importei uma base de dados para o excel,[…]

Função SE + E

Possuo uma base de dados que tem todas as informa&[…]

Formula Procv ou Indice

Preciso organizar os ativos de maiores pesos de ac[…]

A fórmula funcionou, muito obrigada @osva[…]

Experimente: altere Dim EncontraString As Str[…]

Não encontrei nas suas planilhas quaisquer […]

Boa tarde, pessoal! Dúvida, gostaria de sa[…]

Boa tarde, Enviei o anexo em excel.