Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#60064
Bom dia, preciso de uma ajuda dos mestres do Excel. :geek:
Tinha postado esse mesmo problema tempos atrás, mas não tive retorno. Então reformulei a planilha e agora estou em um empasse parecido, mas ainda sem solução.

Tenho uma planilha chamada "DADOS" onde possuo 3 linhas de cabeçalho:

Mostra o número dos casos
Informações técnicas
Dados de itens: Fz, Fx, Fy, Mx, My
- Vale ressaltar nesse ponto, que olhando as colunas dos casos, percebe-se que os dados Fz, Fy, Mx, My não são uniformes para todos os casos. Por exemplo, o caso 1 tem somente Fz, Mx e My; já o caso 2 tem Fz, Fy, Mx, My.

Na 4ª Linha em diante, começam os valores de dados propriamente dita. "Esse formato tem que permanecer porque vem de outro programa"

Da coluna AT até a coluna BB, tem os valores de máximos e mínimos para esses dados.
________________________________________
Pois bem, agora vamos para o que eu preciso:


Na planilha "Maximo" preciso que seja mostrado todos os dados do máximo de cada tipo de item.
Ou seja,
Para P1, sei pela planilha "Dados" que o máximo Fz é 118,5. Dessa forma, a planilha "Maximo Dados" deverá retornar: Caso, Mx, e My. A ideia é parecida para o conjunto "Máximo Mx" e "Máximo My"

Perceba que na planilha "Maximo Dados" já coloquei os valores em vermelho que a planilha deverá retornar como resposta automática (SOLUÇÂO QUE QUERO).
Se for ver, seria quase que um "índice correspondência" modificado porq a matriz de busca é toda quebra na região dos DADOS! :lol:

Logo a formulação deve preencher as colunas B; D; E; G; H; J; L; M; N; :ugeek:

Já tentei de tudo aqui. Mas percebi que com o pouco que sei ainda não da pra fazer. :oops:
Agradeço muito a ajuda de vocês.
Você não está autorizado a ver ou baixar esse anexo.
#60087
Strogonoff escreveu:Boa noite!!!
Que desafio!!!
Veja se era isso que estava esperando...
Tive que apelar para o VBA, talvez devam ter soluçoes no excel , sem vba, mas as particularidades matam ...
Se passou algum bug, me avisa, combinado
Muito bom Strogonoff!! Mandou super bem!
Imaginei mesmo que seria difícil de executar na formulação tradicional;

Estou aprendendo ainda VBA então sei pouca coisa. Mas fiz alguns testes aqui com seu código e só tem um porem;
Na hora de definir as linhas de dados você escreveu:
Código: Selecionar todos
For i = 3 To 65
No entanto a quantidade de linhas pode alterar, tendo mais ou menos valores.. ex: "P200"
Dessa forma, seria interessante alterar o "65" para uma contagem de linhas.
Você pode fazer isso para mim, fazendo favor?

A parte "grossa" do código propriamente dita a partir do "'Encontrando os valores nas matrizes" aí confesso que não entendi kkkk :roll: (Preciso estudar mais);
Então, caso tenha tempo, e puder comentar mais o código, ficarei imensamente grato ;)
Caso não possa, sem problemas :D
#60293
Strogonoff escreveu:Pronto,
veja agora...
Precisando estamos a disposição.
Abraço
Perfeito!! Muito obrigado! :D

OBS: Nâo consegui achar o local aqui no post para colocar o tópico como fechado
#60313
Fiz com fórmulas baseadas no valor das colunas que você já havia preenchido. Fique atento para erros no caso de haver repetição desses valores na mesma linha da aba de Dados.

Para a coluna de caso, uso esta fórmula:
Código: Selecionar todos
=ÍNDICE(Dados!$A$1:$AR$1;CORRESP($C3;Dados!$A4:$AR4;0))
Para as demais colunas, a partir da coluna de caso, combino as funções acima com DESLOC.
Código: Selecionar todos
=ÍNDICE(DESLOC(Dados!$A$1;CORRESP($A3;Dados!$A$2:$A$66;0);CORRESP($B3;Dados!$A$1:$AR$1;0);1;CONT.SE(Dados!$A$1:$AR$1;$B3));CORRESP(D$2;DESLOC(Dados!$A$1;2;CORRESP($B3;Dados!$A$1:$AR$1;0);1;CONT.SE(Dados!$A$1:$AR$1;$B3));0))
Como DESLOC é uma função volátil, é possível que sua planilha fique lenta, dependendo da quantidade de dados.

Por favor, faça testes e nos dê um retorno.
Segue planilha com as fórmulas.

Good luck!
Você não está autorizado a ver ou baixar esse anexo.

Caros, Peço ajuda por gentileza sobre com[…]

Muito obrigado pela ajuda! Saberia informar se exi[…]

Contagem continua

Boa noite Planilha exemplo anexada 1.xlsx

Boa tarde Gostaria de uma ajuda com a seguinte qu[…]

Formula Formatação Condincional

http://ibb.co/FVQ3Mpb http://ibb.co/FVQ3Mpb […]

SOMARPRODUTO - "ANO"

Boa tarde Décio, Ficou excelente, obrigado[…]

Cole uma cópia da fórmula abaixo em […]

ok fico no aguardo, se precisar te envio a planilh[…]