Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por joragene
#59925
Olá pessoal,

Venho pedir ajuda de vocês. Criei uma planilha para registrar a chegada de convidados no evento, com a opção de distribui-los por mesas de 8 lugares e 10 lugares. Essa lista de convidados já se encontra preenchida previamente com os nomes, bastando marcar a presença com um "x", para que a planilha pegue o cargo e o nome do convidado e posicione no desenho da mesa.
O problema é que se houverem no meio da lista, convidados que faltarem, o local na mesa fica vago. Gostaria de obter uma fórmula que calculasse dinamicamente a posição dos convidados presente à mesa, quando outros convidados faltarem. Sera se tem como?
Enviando arquivo de exemplo...
MESA DE HONRA.xlsx
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Estevaoba
#59928
Use esta fórmula matricial (Cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter) na célula I35:
Código: Selecionar todos
=SEERRO(ÍNDICE($A$2:$A$100;MENOR(SE($E$2:$E$100="X";LIN($A$2:$A$100)-1);1));"")
Altere manualmente o k da função MENOR para as outras posições, por exemplo, para H35:
=SEERRO(ÍNDICE($A$2:$A$100;MENOR(SE($E$2:$E$100="X";LIN($A$2:$A$100)-1);2));"")

Good luck!
joragene agradeceu por isso
Por joragene
#60017
Estevaoba escreveu: 24 Out 2020 às 15:00 Use esta fórmula matricial (Cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter) na célula I35:
Código: Selecionar todos
=SEERRO(ÍNDICE($A$2:$A$100;MENOR(SE($E$2:$E$100="X";LIN($A$2:$A$100)-1);1));"")
Altere manualmente o k da função MENOR para as outras posições, por exemplo, para H35:
=SEERRO(ÍNDICE($A$2:$A$100;MENOR(SE($E$2:$E$100="X";LIN($A$2:$A$100)-1);2));"")

Good luck!
Obrigado pela ajuda.

Por favor, envia uma amostra das suas bases de dad[…]

Boa tarde! Criar uma formatação con[…]

Renato, A planilha em anexo para precisa digitar[…]

Exportação CSV

Quando faço a exportação de u[…]

Em C5: =SEERRO(SE(PROCV(B3;'Registro Pendencia'!A[…]

Macro Relatório Diário

Bom dia pessoal! Preciso de ajuda para elaborar um[…]

Olá, @brunoangelo . Sugestão, d[…]

Calculo horas power query

Boa noite, pessoal Tenho um problema que ainda n&[…]