Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por Pegorini
#59746
Boa Tarde Senhores.

Estou com dificuldade com o uso da função PROCV. Não sei se essa função solucionará meu problema pelos seguintes motivos:

Na função PROCV acredito que só posso procurar um valor, porém eu tenho 2 a ser procurado, então não sei o que fazer.

Na minha planilha neste anexo em D3 deve apresentar como resultado 16% conforme a tabela.

Sendo assim gostaria de ajuda para este problema.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Estevaoba
#59747
Editei para observar que a informação em C3 da aba Apuração deve estar com o item IDÊNTICO ao listado na coluna B da aba Tabela. Notei que na aba tabela há um espaço depois dos valores e na aba Apuração não tinha esse espaço.

Resolvida a discrepância acima, seguem duas opções de fórmula:
Esta matricial. Cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter:
Código: Selecionar todos
=ÍNDICE(Tabela!D2:D18;CORRESP(B3&C3;Tabela!A2:A18&Tabela!B2:B18;0))
Ou esta não matricial:
Código: Selecionar todos
=ÍNDICE(Tabela!D2:D18;CORRESP(B3;Tabela!A2:A18;0)+CORRESP(C3;Tabela!B2:B18;0)-1)
Good luck!
laennder, Pegorini agradeceu por isso
Por Pegorini
#59786
Oi Estevaoba.

Muito obrigado pela ajuda.


A fórmula matricial deu certo, mas a não matricial não.

Se não for pedir muito poderias me informar o que pode ter ocorrido?
Avatar do usuário
Por Estevaoba
#59827
O funcionamento da fórmula não matricial requer que os dados estejam exatamente como você colocou no modelo, ou seja, 6 faixas para cada anexo.
No caso de B3=ANEXO III e C3=4º, a primeira CORRESP retorna 13, a linha correspondente ao texto do primeiro critério (B3). A segunda CORRESP retorna 4, a linha correspondente ao segundo critério (C3). E para corrigir a sobreposição da soma dos dois valores, subtraio 1.
Portanto, é possível que os dados na sua planilha real não sigam rigorosamente esse padrão.
Seria interessante você postar outro modelo com dados em que a fórmula resulta erro.

Ab.
Por Pegorini
#59952
Olá Estevaoba

Anexo a planilha original. a fórmula está na coluna E da planilha "Apuração"

Se puderes me ajudar em saber o que está de errada na fórmula, ficarei muito grato.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Estevaoba
#59955
Encontrei dois erros:
1. A fórmula em E2 estava buscando a linha 3, em vez da linha 2, então corrigi C3 para C2 e D3 para D2:
Código: Selecionar todos
=ÍNDICE(Tabela!$C$2:$C$31;CORRESP(C2;Tabela!$A$2:$A$31;0)+CORRESP(D2;Tabela!$B$2:$B$31;0)-1)
2. Os valores na coluna B da aba Tabela ainda têm espaço depois dos números ordinais em algumas linhas, por exemplo da linha 2 a 16, ocasionando erro no resultado da segunda CORRESP. Elimine esses espaços para que a CORRESP encontre a linha correta.

Ab.
Pegorini agradeceu por isso
Copiar Aba e colar em nova aba

Substitua Set wsTag = Sheets("Planilha1&quo[…]

Copiar colunas em nova guia

Bom dia!! clique em <ALT + F11> e abre a t[…]

incompatibilidade

Gustavo Bom dia!! O libre office realmente é[…]

Dúvida sobre tabela dinâmica

Existe a possibilidade de ter toda a informa&ccedi[…]

Função SE

Muito obrigado pelas respostas . Funcionou perfeit[…]

Boas tudo bem? Seria possível deixar um exe[…]

Ainda bem que conseguiu :) Eu ja estava a semanas[…]

Boa noite!! Antes de tudo queria parabenizar pelo […]