Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por marcolucio84 15 Abr 2019 às 15:26
Membro Novato
Mensagens: 4
Reputação: 0
#43086
Boa tarde a todos!
Estou com dificuldades para entender o erro que venho recebendo para essa função

=SE(CONT.NÚM(F7:F19)=1;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=2;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=3;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=4;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=5;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=6;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=7;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=8;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=9;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=9;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=10;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=11;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SE(CONT.NÚM(F7:F19)=12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12);0))))))))))))

O erro diz numero excessivo de argumentos, o que exatamente isso quer dizer? O Objetivo dessa função é fazer uma média do faturamento a medida que a planilha é preenchida. Por exemplo como estamos no mes de Abril, já tenho 3 valores fechados referentes a Jan/Fev/Mar, ele basicamente tem que somar esses tres meses dividir por 3 e multiplicar por 12 para fazer uma projeção simples do faturamento anual. A formula está bem extensa, e agradeço qualquer ajuda para otimizar isso!

Obrigado.
Avatar do usuário
Por FelipeMGarcia 15 Abr 2019 às 15:32
Excel Expert
Mensagens: 3457
Reputação: 1439
#43087
Marco, anexa um modelo da sua planilha que fica mais fácil de ajudar, se possível coloque o resultado desejado só pra validar a fórmula, para anexar o arquivo, vá em + resposta, adicionar anexo.

abs
Avatar do usuário
Por Deciog 15 Abr 2019 às 16:03
Membro 5 Estrelas
Mensagens: 1076
Reputação: 538
#43090
marcolucio84


Na sua formula você colocou duas vezes = 9, mais isso não o erro da formula

Eu usaria desta forma pois é uma sequencia de 1 até 12

=ESCOLHER(CONT.NÚM(F7:F19);SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12)

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Por marcolucio84 15 Abr 2019 às 17:39
Membro Novato
Mensagens: 4
Reputação: 0
#43099
Segue a planilha para auxilio. A Formula está com um != na célula que quero que mostre a soma, a ideia é que se você colocar qualquer valor na mesma coluna acima ele já refaça o calculo. Eu achei um erro de referencia circular na formula e corrigi mas mesmo assim ela continua dando o erro de excesso de argumentos.

Novamente Obrigado pela ajuda.
Apenas usuários registrados podem ver ou baixar anexos.
Por marcolucio84 15 Abr 2019 às 17:40
Membro Novato
Mensagens: 4
Reputação: 0
#43100
Deciog escreveu:marcolucio84


Na sua formula você colocou duas vezes = 9, mais isso não o erro da formula

Eu usaria desta forma pois é uma sequencia de 1 até 12

=ESCOLHER(CONT.NÚM(F7:F19);SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12)

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio


Vou experimentar a formula e já resopondo se funcionou.
Avatar do usuário
Por FelipeMGarcia 15 Abr 2019 às 17:50
Excel Expert
Mensagens: 3457
Reputação: 1439
#43101
Amigo, veja se o que fiz lhe ajuda, caso queira agradecer, clique na mãozinha.

aBs
Apenas usuários registrados podem ver ou baixar anexos.
Por marcolucio84 15 Abr 2019 às 18:45
Membro Novato
Mensagens: 4
Reputação: 0
#43105
Deciog escreveu:marcolucio84


Na sua formula você colocou duas vezes = 9, mais isso não o erro da formula

Eu usaria desta forma pois é uma sequencia de 1 até 12

=ESCOLHER(CONT.NÚM(F7:F19);SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12;SOMA(F7:F18)/CONT.NÚM(F7:F18)*12)

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio



Funcionou, vc poderia me explicar mais ou menos como a função escolher funciona?
Avatar do usuário
Por FelipeMGarcia 15 Abr 2019 às 18:58
Excel Expert
Mensagens: 3457
Reputação: 1439
#43107
=(SOMA(DESLOC($F$6;1;0;CONT.SE($F$7:$F$19;">0")))/CONT.SE($F$7:$F$19;">0"))*12
Avatar do usuário
Por Deciog 16 Abr 2019 às 09:42
Membro 5 Estrelas
Mensagens: 1076
Reputação: 538
#43123
marcolucio84

Acho que não precisa da função ESCOLHER pois somente esta =SOMA(F7:F18)/CONT.NÚM(F7:F18)*12 já obtêm o valor que você quer, confere

Para você ver as opções de qualquer função basta você selecionar a célula e clicar na função, ela ira para o suporte o office, vai mostrar exemplo e explicacao, teste

link https://support.office.com/pt-br/articl ... t-BR&ad=BR

Decio