Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por sic 11 Fev 2019 às 11:47
Membro Novato
Mensagens: 4
Reputação: 0
#41090
Bom dia pessoal,
Preciso de uma ajuda com relação a esta planilha que deixei em anexo.
Nela tem um comentário sobre o que eu quero.
Se alguém puder ajudar eu agradeço.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 11 Fev 2019 às 14:02
Membro 4 Estrelas
Mensagens: 324
Reputação: 133
#41096
Código: Selecionar todos=UNIRTEXTO(", ";1;SEERRO(ÍNDICE($D$1:$F$1;;MENOR(SE(D2:F2=MENOR(D2:F2;1);COL(D2:F2)-3);1));"");SEERRO(ÍNDICE($D$1:$F$1;;MENOR(SE(D2:F2=MENOR(D2:F2;1);COL(D2:F2)-3);2));""))


Fórmula matricial. Cole e confirme pressionando ctrl, shift, enter simultaneamente.

Good luck!
Avatar do usuário
Por Estevaoba 11 Fev 2019 às 19:33
Membro 4 Estrelas
Mensagens: 324
Reputação: 133
#41115
A função UNIRTEXTO está disponível a partir do Office 2016.
Se o seu Office for anterior, tente esta fórmula, também matricial:

Código: Selecionar todos=SEERRO(ÍNDICE($D$1:$F$1;;MENOR(SE(D2:F2=B2;COL(D2:F2)-3);1));"")&", "&SEERRO(ÍNDICE($D$1:$F$1;;MENOR(SE(D2:F2=B2;COL(D2:F2)-3);2));"")


Para confirmar se a fórmula matricial foi executada corretamente, verifique se aparecem chaves { } cercando a fórmula na barra de fórmulas. Essas chaves são exibidas automaticamente ao pressionar simultaneamente as teclas Ctrl, Shift, Enter.

Ab.
Por sic 12 Fev 2019 às 08:49
Membro Novato
Mensagens: 4
Reputação: 0
#41126
Obrigado pela ajuda Estevaoba!!
Estou usando o Office 2016, entretanto não possui a função "Unirtexto". Me pareceu bastante útil. Pena não ter.
A fórmula que passara sem esta função (unirtexto) funcionou.
Perfeito!!
Mais uma vez, obrigado.
:D