Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
#68212
Pessoal, boa tarde!

Antes de postar aqui tentei de tudo, olhei alguns tópicos que ensinava a fazer com índice e correspondente, testei com SE(E(, testei com SE(Procx e testei tabela dinâmica infelizmente não consegui.

Preciso trazer a informação cargo e para chegar nessa informação preciso procurar entre duas colunas com data início e fim e uma condição.

Meu Excel é o 365, vou colocar uma base da planilha pra ver se conseguem me ajudar com isso.
PS. vão ter alguns com data 31/12/9999 significa que o funcionário ainda não saiu da empresa.

Obrigado desde já a todos.
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por Roohliberato em 08 Dez 2021 às 11:11, em um total de 1 vez.
#68218
Galera, estou com uma dúvida parecido do colega.
Onde preciso segregar as informações abaixo, conforme o ":" , "," e em especial " CodTabelaICM de 143 p/ 741" separando antes e depois, tipo uma coluna para 143 e outra para 741.
"Empresa:5: Atacado-Aliq.PIS de 0,65 p/ 0, Varejo-Aliq.PIS de 0,65 p/ 0, Atacado-Aliq.COFINS de 3 p/ 0, Varejo-Aliq.COFINS de 3 p/ 0, CodTabelaICM de 143 p/ 741, CEST de p/ "

E para bagunçar minha vida, o além da segregação acima o código do produto está na linha de cima da sequencia de informações que estão todas juntas, preciso trazer o numero do produto para mesma linha dos itens separados.

Tipo Estação Usuário Data Hora Tabela Chave Rotina
Ocorrência
Aud CAIXA JENNIFER 13/11/2021 10:21:00 Produtos 41 fCadastroNCM
Empresa:5: Atacado-Aliq.PIS de 0,65 p/ 0, Varejo-Aliq.PIS de 0,65 p/ 0, Atacado-Aliq.COFINS de 3 p/ 0, Varejo-Aliq.COFINS de 3 p/ 0, CodTabelaICM de 143 p/ 741, CEST de p/


Como imagino

41|empresa|5|Codtabela| 143|741

Grato!!!
Você não está autorizado a ver ou baixar esse anexo.
#68224
DJunqueira escreveu: 08 Dez 2021 às 10:20 Parabéns por informar a versão do Excel :!: :D
Código: Selecionar todos
=ÍNDICE(Base!$E$3:$E$28;CORRESPX(1;(Base!$B$3:$B$28=B3)*(Base!$C$3:$C$28<=Cargo!E3)*(Base!$D$3:$D$28>=Cargo!E3);0))
Confirme se o resultado era o esperado.
Obrigado por ter tirado um pouco do seu tempo e ter me auxiliado, imaginei mesmo que fosse possível utilizar as fórmulas ÍNDICE e CORRESPONDENTE, no entanto não consegui.

Me ajudou demaaaaaais

Por exemplo, na linha 2 da planilha anexada, na […]

BUSCAR DADOS EM OUTRA ABA

preciso buscar informação de nome e […]

Como seria no excel, por exemplo, este calculo?

Deu Certo Amigo. Obrigado

Boa tarde! Patropi. Por tratar-se de uma conta co[…]

Ajuda na Formula

Através da imagem não dá para[…]

pode anexar seu pbix?

Today I will introduce the member of the Eleaf Ba[…]