Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por LUCASGUARDIA
#66161
Ola boa noite a todos, comecei uma tabela um tanto quanto complexa (para mim) e boa parte do que gostaria de fazer ja consegui porem parei em um problema que não consigo achar solução, já tentei vários tutorias e vídeos porem nada funciona, então venho aqui pedir a ajuda de voces, pois bem, nessa tabela possuo tres colunas chaves "localizadores" , "localizadores tratados" e "nao tratados", a tabela localizadores é uma EXT.TEXTO aonde eu pego códigos localizadores de outro texto que tambem esta na tabela, e tratados é uma SENÃODISP(PROCV) aonde eu busco localizadores que ja foram mexidos na lista de localizadores e ele me retorna os que ja foram mexidos ou me retorna 0 no caso os que não foram mexidos e a ultima tabela a "não tratados" aonde eu uso SENÃODISP(PROCV) pra buscar os locs na tabela de tratados, caso sejam encontrados ela me retorna verdadeiro, e caso nao seja ela me retorna o proprio localizador implicando assim que o mesmo não foi tratado.

pois bem mas qual o problema? a organização, eu gostaria de deixar aparecendo nos tratados e nos não tratados apenas o localizador em ordem de cima pra baixo sem aparecer os verdadeiros ou os 0, já tentei varias formas e nada funciona pois como uso muitas linhas a tabela foge de formação sempre que tento algo, filtros também não funcionam pois as funções mudam como mudo linhas, enfim vou deixar as fotos pra ficar de mais fácil entendimento.
Imagem
Imagem
Imagem

Grato desde ja
Por osvaldomp
#66168
Olá, @LUCASGUARDIA .

Sugestão: disponibilize uma amostra do seu arquivo Excel (imagens não servem) com alguns dados (máximo 10 a 15 linhas representativas) e coloque manualmente os resultados desejados em cada coluna.
LUCASGUARDIA agradeceu por isso
Por LUCASGUARDIA
#66176
Boa noite! obrigado pelo retorno, segue uma tabela com o problema o que eu gostaria de resolver


obrigado desde ja
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#66211
Olá, @LUCASGUARDIA .

Veja se atende.

1. para reproduzir os itens da coluna A sem repetição, cole uma cópia da fórmula abaixo em R4 e estenda pela coluna.
Código: Selecionar todos
=SEERRO(EXT.TEXTO(ÍNDICE(A$5:A$21;CORRESP(0;CONT.SE(R$3:R3;EXT.TEXTO(A$5:A$21;6;6));0));6;6);"")
#
2. em S4
Código: Selecionar todos
=SEERRO(ÍNDICE(C$16:C$21; MENOR(SE(CONT.SE(R$4:R$24; C$16:C$21); CORRESP(LIN(C$16:C$21);LIN(C$16:C$21)); ""); LINS(A$1:A1)));"")
#
3. em T4; em seguida selecione S4:T4 e estenda pelas colunas
Código: Selecionar todos
=SEERRO(ÍNDICE(C$16:C$21; MENOR(SE(CONT.SE(R$4:R$24; C$16:C$21); CORRESP(LIN(C$16:C$21);LIN(C$16:C$21)); ""); LINS(A$1:A1)));"")
#
obs. a célula A15 "parece" vazia, no entanto há "sujeira" invisível nela e por isso aparecerá também uma célula "vazia" na coluna T; para regularizar basta selecionar A15 e apertar Delete .
Por LUCASGUARDIA
#66284
Bom dia amigo, obrigado pela ajuda, infelizmente não funcionou, as colunas ficam todas em branco ao colar essas funções.
Por osvaldomp
#66290
Veja o arquivo anexado com as fórmulas.
Você não está autorizado a ver ou baixar esse anexo.
Por LUCASGUARDIA
#66316
Olá Osvaldo, baixei aqui e realmente está funcional do jeito que eu queria, porém ao passar pra minha planilha ela não estão funcionando e eu não sei k porque, o resultado da função está certo porém por algum motivo me retorna erro, segue os prints, já tentei absolutamente de tudo e não sei oq pode ser
Imagem
Imagem
Por osvaldomp
#66318
Faça um teste aí. Selecione R4 no seu arquivo (já com a fórmula que não funciona corretamente), aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter (para inserir como fórmula matricial). Se funcionar estenda pela coluna.

Se não funcionar então disponibilize o seu arquivo com as fórmulas.

Obrigado pela colaboração :D :D

Boa tarde Pessoal, Preciso criar uma coluna na mi[…]

DESCOBRIR TAJA DE JUROS AO DIA

Boa tarde a todos, Estou com uma relaç&ati[…]

Configurar impressão

Tenho um botão na minha planilha Excel de i[…]

Criar gráfico de Pareto

Muitoo obrigado, deu certinho!! Vou dar uma estuda[…]

Planilha Lenta (Fórmula Matricial)

Caríssimo osvaldomp - 22 Set 2021 à[…]

Boa Tarde! Prezado Basole - 21 Set 2021 às[…]

Boa tarde, não estou conseguindo fazer a f&[…]