Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por marcosdolzany
#65055
Senhores,
Tenho um relatóro que é emitido pelo sistema no formato que esta no anexo. Tal relatório é sempre exportado pro excel no mesmo formato, porém A POSIÇÃO DA CÉLULAS DE SOMA mudam de posição conforme a produção de cada médico.
Na aba 668 eu colo o relatório exportado pelo sistema....
Na aba APURA tenho o nome dos médicos. Nessa aba preciso somar o valor que cada médico tem direito a receber, sendo que:
o nome do medico está na COLUNA A e o valor a ser somado está na COLUNA E. Porém o valor que tem quer ser considerado o que está na linha onde está escrito a palavra "TOTAL CONVÊNIO". Aí está minha dificuldade pois essa linha sempre muda de lugar....
Tem mais uma coisa: na coluna A a posição dos nomes do médicos também muda de lugar a cada relatório emitido

Antecipadamente, agradeço
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Estevaoba
#65056
Sugiro criar uma coluna auxiliar na aba 668 para indexar as linhas conforme os nomes da coluna A, com esta fórmula em K2, por exemplo, e copiada para baixo:
Código: Selecionar todos
=SE(E2="";"";SE(A2="";K1;A2))
E na aba Apura, esta fórmula em B2, copiada para baixo:
Código: Selecionar todos
=MÁXIMO(SE('668'!$K$6:$K$1000=A2;'668'!$E$6:$E$1000))
Fórmula matricial. Cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter.
Good luck!
marcosdolzany agradeceu por isso
Por osvaldomp
#65070
#
Segue uma alternativa. Em B2 da planilha APURA e arraste para baixo.
Código: Selecionar todos
=ÍNDICE('668'!E$5:E$161;MENOR(SE('668'!B$5:B$161="Total Convênio";LIN(B$5:B$161)-4);LIN(A1)))
marcosdolzany, Estevaoba agradeceu por isso
Ranking PROCV

... mas fiz as alterações correspo[…]

Bom dia comunidade! Preciso implementar uma solu&[…]

Pessoal Boa noite. Tenho uma planilha, que escrev[…]

Saldos

Olá, estou fazendo um dashboard e tenho um[…]

Deve ter outra forma, mas sugiro que faça n[…]

Tente esta: Acc = CALCULATE ( [Receita], […]

AJUDA COM FUNÇÃO "SE"

O problema não é devido ao uso da fu[…]

Veja no link abaixo se aproveita algo. https://w[…]