Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por baldman
#63575
Imagem

Boa tarde, estou criando uma planilha de vendas para um mercado fictício e estou tendo problemas em acertar a função de valor de entrega(frete) com uma macro.

Criei uma célula que recebe uma certa região e auto completa o valor de entrega com um valor tabelado(usando índice e corresp), se o cliente(id), data e a região forem a mesma da linha abaixo(múltiplas compras do mesmo cliente), eu deixo o valor de entrega como 0, e só na última linha é adicionado o valor do frete, faço isso pq esses valores vão ser somados no final e nao faz sentido o cliente pagar mais de uma vez o frete pro mesmo lugar no mesmo dia.

Fórmula: =SE(E([@Id]=B6;[@[Data da Venda]]=C6;[@Entrega]=J6);0;SEERRO(ÍNDICE(cálculos!$A$6:$B$10;CORRESP([@Entrega];cálculos!$A$6:$A$10;0);2);0))

Isso ta funcionando perfeitamente, o problema vem com a macro para apagar uma venda selecionada: selecionada uma célula qualquer de uma linha e clicando no botão essa linha é excluída.
O que acontece é que após usar a macro, a linha superior a linha apagada perde a referência a linha inferior, aparecendo #REF.
Como eu poderia fazer para que a fórmula e a macro funcionem juntas?
Desde já agradeço pela ajuda.
#63578
gostei da sua macro, muito legal !
o que eu faria ao incluir uma nova venda seria colocar uma macro que coloca a formula, calcular a planilha, e substituir a fórmula pelo valor calculado do frete, isto é, deixaria a célula sem fórmula mesmo.
Então ao excluir ele não daria problema de fórmula, porém vc precisa tomar cuidado que se ele excluir a primeira linha que tem o valor do frete vai dar problema.
Talvez o ideal seja colocar o frete em outra tabela, nas modelagens de dados que tenho feito não costumo misturar frente com os itens da venda.

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]