Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#63539
Olá Galera,

Venho aqui buscar auxílios pois não consigo chegar no resultado, vou tentar explicar:
Tenho um base de dados contendo lançamentos de atestado dos colaboradores, tenho que quantificar quantos dias de atestado ocorreram em um período de dias, estou usando a formula somarproduto, o problema é quando informo a data inicial e final para buscar as quantidades resultado não fica correto para o período que inicia dentro da data inicial e sai muito da a data final, exemplo anexo!
Grato pela atenção!
Aguardo!
Você não está autorizado a ver ou baixar esse anexo.
#63542
Veja se é isso. Se não for, tente explicar qual o resultado de cada um e como chegou neste resultado. Assim ficará mais fácil de entender oq deseja.
Você não está autorizado a ver ou baixar esse anexo.
anacletotranstusa agradeceu por isso
#63546
Olá
Desde já agradeço sua atenção, mas não deu certo. O resultado que necessito está relacionado a inserção do período:
Exemplo:
Período: 20/01/2021 até 23/01/2021 informado na célula J1 e K1
Dentro desse período informado a formula deve contar a quantidade de dias que estiver dentro dos registros entre as data_1 e data_2 por Código CID da tabela de registros.
Na tabela que consta os dados já tem uma coluna contendo o número de dias de cada registro, no entanto, preciso fazer esse cálculo personalizado informando o período para que a formula conta os dias dentro desse período informado.
Anexo a planilha preenchida com os valores desejados.

Aguardo!
Você não está autorizado a ver ou baixar esse anexo.
#63557
Olá
Grato, mas não seria esse o resultado que desejo, é confuso explicar eu anexei outra planilha de exemplo, eu preciso quantificar quantos dias de atestado dentro do intervalo de data informada no período por CID, na planilha de exemplo destaquei em amarelo (Coluna L3:L8) o resultado desejado entre o período informado 20/01/2021 a 28/01/2021 na coluna M3:M8 detalhei os resultados.
Desde já agradeço!
Você não está autorizado a ver ou baixar esse anexo.
#63559
Código: Selecionar todos
=SOMARPRODUTO(CONT.SES($C$2:$C$10;"<="&LIN(INDIRETO($I$1&":"&$J$1));$D$2:$D$10;">="&LIN(INDIRETO($I$1&":"&$J$1));$A$2:$A$10;J3))
Você não está autorizado a ver ou baixar esse anexo.
anacletotranstusa agradeceu por isso
#63562
#
No arquivo do post #63557:

Em G2 e arraste para baixo:
Código: Selecionar todos
=MÍNIMO(K$1;E2)-MÁXIMO(J$1;D2)+1
#
Em M3 e arraste para baixo:
Código: Selecionar todos
=SOMARPRODUTO((J$1<=D$2:D$10)*(A$2:A$10=K3)*(G$2:G$10))
anacletotranstusa agradeceu por isso
#63569
Olá osvaldomp,
Sua solução foi interessante por ser simples, tentei tratar os valores negativos e não consegui, adicionei uma condição se para mostrar o valor 0 quando as datas não condizem com a data consultada mas não tive sucesso, poderia me auxiliar?

@ babdallas agradeço pela sua solução com sua formula conseguir o resultado esperado! muito obrigado!
#63571
anacletotranstusa escreveu: 08 Abr 2021 às 09:18 ... tentei tratar os valores negativos e não consegui, adicionei uma condição se para mostrar o valor 0 quando as datas não condizem com a data consultada...
Se não houver intersecção entre os intervalos de datas então a segunda fórmula que passei retornará zero, que está correto.
Se nesses casos você quiser que a primeira fórmula retorne zero e não negativo, então experimente esta abaixo no lugar.
Código: Selecionar todos
=SE(OU(J$1>E2;K$1<D2);0;MÍNIMO(K$1;E2)-MÁXIMO(J$1;D2)+1)
anacletotranstusa agradeceu por isso
#63586
Olá,
Minha base de dados contem um período grande de datas, a formula "=SE(OU(J$1>E2;K$1<D2);0;MÍNIMO(K$1;E2)-MÁXIMO(J$1;D2)+1)" resolveu o problema entre as datas inferiores a da informada na consulta, porem agora os intervalo posterior ficou negativo, ou seja quantos dia falta para as futuras datas, tem como solucionar?

Desde já agradeço sua atenção!
#63591
anacletotranstusa escreveu: 08 Abr 2021 às 14:34 ... porem agora os intervalo posterior ficou negativo, ou seja quantos dia falta para as futuras datas, ...
Não entendi o que você quis dizer. Para facilitar o entendimento é desejável que você informe SEMPRE os endereços das células a que está se referindo e com exemplos.
Experimente a fórmula abaixo em M3.
Se não for isso então disponibilize um novo arquivo com exemplos, com as fórmulas, e aponte os resultados indesejados.
Código: Selecionar todos
=SOMASE(A$2:A$10;K3;G$2:G$10)
anacletotranstusa agradeceu por isso

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]