Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#63530
Boa noite.

Alguém poderia me apontar qual o problema e correção que deve ser feita na Macro de Classificação da planilha anexa.

Uso a mesma macro em várias tabelas e nesse caso especificamente está apresentando problemas quando incluo o Passo = 3.

Poderiam verificar por gentileza?

Segue planilha anexa.
Você não está autorizado a ver ou baixar esse anexo.
#63555
oi, boa noite, acredito que esta planilha tenha a estrutura um pouco diferente das outras, eu removi a coluna A e deu certo, veja se não é isso.
Você não está autorizado a ver ou baixar esse anexo.
SandroLima agradeceu por isso
#63573
Bom dia.

Obrigado pela intenção de ajudar, amigo.

Com a ajuda de um membro do fórum identifiquei o problema. Era um erro na referência da coluna.

Basta substituir a linha:
Código: Selecionar todos
Col_Reg = Tabela.ListColumns("Registro").DataBodyRange.Column - Col_Zero
Por:
Código: Selecionar todos
Col_Reg = Tabela.ListColumns("Registro").DataBodyRange.Column

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]