Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#63470
Boa noite, pessoal

Mais uma vez estou precisando de uma ajudinha com uma fórmula.

Na planilha em anexo preciso que a Coluna [Qtde Atual] retorne a quantidade de Ativos Atual (Diferença entre comprados e vendidos) mas que esse resultado somente seja retornado na data mais recente de lançamento do Ativo ou seja na última posição realizada do ativo.

A coluna Corretora deve ser considerada no cálculo da Qtde Atual do Ativo assim como a fórmula atual faz.
Isso porque os Ativos Iguais porém de Corretoras Diferentes devem ser considerados "Diferentes" entre si.
Mas a fórmula Atual já faz isso.
Notem que o Ativo GOAU4, por exemplo, tem duas linhas apresentando resultados da quantidade do Ativo.
Isso é pq ele tem posições montadas em duas Corretoras Diferentes.

Preciso agora considerar a Data no cálculo da fórmula para que ela retorne o resultado somente na linha da última movimentação do ativo (Data mais recente) .

As Datas mais antigas ou os ativos com posição zerada devem retornar "-".

Inseri uma Coluna com o Resultado Desejado colocado manualmente.

Deixo outras explicações na própria planilha anexa.
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por SandroLima em 02 Abr 2021 às 17:19, em um total de 1 vez.
EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]

Boa tarde!! Tenho uma planilha para calculo de ho[…]