Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por Bujha
#63388
Boa tarde,

Preciso de ajuda para criar uma lista suspensa "dependente" com base na informação da coluna anterior
exemplo;

Coluna A Coluna B
A1 FORNECEDOR B1 PRODUTO
A2 XXXX1 B2 abc
A3 XXXX1 B3 cba
A4 XXXX2 B4 xyz
A5 XXXX2 B5 zxy
A6 XXXX1 B6 123

Lista 1 Lista2
XXXX1 abc
cba
123


Obrigado.
#63392
Você quer escolher o produto e mostrar somente os fornecedores daquele produto?
Anexa.um exemplo em Excel para facilitar, por favor.
Por Bujha
#63448
Boa tarde a Todos!
peço desculpa por retornar tão tarde mas a semana tem sido complicada :?

Em anexo a planilha com o a estrutura que gostaria de ter.
Na folha "PEDIDO DE COMPRA" tem na coluna G os fornecedores numa lista que vai pegar a informação à folha "FORNECEDOR". na coluna ao Lado (H)tem o código e aí eu gostaria com base na informação da coluna G fosse à folha" PRODUTO" e numa lista selecionar apenas os produtos desse fornecedor.

Versão do excel 2016

Obrigado pela ajuda!
BD fornecedor.xlsm
Você não está autorizado a ver ou baixar esse anexo.
#63449
Fiz com coluna auxiliar na aba produto, com esta fórmula em J6 e copiar até J41:
Código: Selecionar todos
=SEERRO(ÍNDICE(Tabela2[CÓDIGO];AGREGAR(15;6;((Tabela2[FORNECEDOR]='PEDIDO DE COMPRA'!$G$7)/(Tabela2[FORNECEDOR]='PEDIDO DE COMPRA'!$G$7)*(LIN((Tabela2[FORNECEDOR]))-5));LIN(A1)));" ")
E na validação de dados na aba pedido de compra, esta fórmula:
Código: Selecionar todos
=DESLOC(PRODUTO!$J$6;;;CONT.SE(PRODUTO!$J$6:$J$41;"<> ");1)
Good luck!

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]