Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
#62372
Boa tarde,

Estou a ter dificuldades em aplicar a formula SE ou o criterio superior a uma data juntamente a formula PROCV para encontrar um resultado.
exemplo:
estou aplicar a formula PROCV na planilha "2019" na coluna F, mas devolve me o resultado na data inferior ou igual, e eu desejo apanhar só os resultados superiores a data da coluna F "Data emissão da FMA".
vou buscar a informação a planilha "FMA's Apto"

podem, por favor dar-me informação como posso construir a formula?

Adicionei o meu ficheiro para ser mais claro

obrigado desde já
Você não está autorizado a ver ou baixar esse anexo.
#62387
Domingues, Bom DIa.

Explica melhor, digita o resultado esperado, pois, estou com duvida, voce escreve "superiores a data da coluna F " mas no PROCV não é procurado por data, explica melhor o que desejas

Decio
Domingues agradeceu por isso
#62393
Imagemboa tarde @Deciog decio,
O meu objetivo é encontrar uma ficha medica com data superior a ficha medica que tenho na planinha “2019”.

o amarelo é a minha referência(planinha 2019), e vou buscar o resultado das colunas azul a planilha FMA's Apto:
Devolveu me resultado de uma ficha medica inferior a minha referencia,a minha refrencia é de 02/01/2019 e devolveu um resultado de 28/02/2018:
https://i.imgur.com/6Yogtnr.png


O que pretendo é só os resultados com data superior, como este exemplo:
https://i.imgur.com/lS4QppG.png

não sei como aplicar o filtro de data na formula.
Aproveito para esclarecer mais um duvida, é possível devolver mais que um resultado caso o funcionário tenha mais que uma ficha médica? ou alguma formula que diga que existe quantos resultados temos para o mesmo funcionário?
Obrigado
Imagem
Imagem
Você não está autorizado a ver ou baixar esse anexo.
#62407
Para que as fórmulas funcionem, converta para data os valores da coluna D.
Selecione todo o intervalo e use a ferramenta Texto para colunas da faixa Dados, sendo que na última tela selecione Data.

Feito isso, seguem opções de fórmulas matriciais (Confirme com Ctrl+Shift+Enter simultaneamente) para colar na célula F3 e copiar para G3 e para baixo:
Código: Selecionar todos
=SEERRO(ÍNDICE('FMA''s Apto'!F:F;MENOR(SE('FMA''s Apto'!$A:$A=$A3;SE('FMA''s Apto'!$G:$G>=$D3;LIN('FMA''s Apto'!$A:$A)));1));"NA")
Para reduzir o tempo de processamento, não use toda a coluna. Restrinja o cálculo para um intervalo determinado como neste exemplo:
Código: Selecionar todos
=SEERRO(ÍNDICE('FMA''s Apto'!F$2:F$100000;MENOR(SE('FMA''s Apto'!$A$2:$A$100000=$A3;SE('FMA''s Apto'!$G$2:$G$100000>=$D3;LIN('FMA''s Apto'!$A$2:$A$100000)-1));1));"NA")
Para exibir todos os resultados na mesma célula, repita as fórmulas acima, mudando apenas o último algarismo numérico de 1 para 2, ou 3, etc. e junte com a função UNIRTEXTO ou CONCATENAR.

Se você estiver usando Excel na versão 365, essa tarefa fica muito mais simples com estas fórmulas não matriciais:
Em F3, copiado para baixo:
Código: Selecionar todos
=UNIRTEXTO("; ";1;FILTRO('FMA''s Apto'!F:F;('FMA''s Apto'!$A:$A=$A3)*('FMA''s Apto'!$G:$G>=$D3);"NA"))
E em G3:
Código: Selecionar todos
=UNIRTEXTO("; ";1;TEXTO(FILTRO('FMA''s Apto'!G:G;('FMA''s Apto'!$A:$A=$A3)*('FMA''s Apto'!$G:$G>=$D3);"NA");"dd/mm/aaaa"))
Good luck!
Domingues agradeceu por isso
Procurar valor em um texto

=ESQUERDA(V2;LOCALIZAR(",";V2)-1) Conseg[…]

cont.se com ext.texto

Bom dia, Estou tentando unir as fórmula[…]

Ventura , Bom dia. Obrigado pelo feedback. Fico[…]

thaisdoo , Bom dia. Obrigado pelo feedback. Fic[…]

Você não esta conseguindo porque os […]

Ajuda com botões em linhas.

Veja se esta solução ajuda. Funcion[…]

Segue uma ideia. Aplique Formataçã[…]

Boa tarde, AfonsoMira. Funciona sim... Muito obri[…]