Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
#61770
Boa Tarde Pessoal,

Tenho uma situação e não estou conseguindo resolver e gostaria de saber se alguém pode me ajudar:

Preciso procurar um valor em uma celula que possui vários valores divididos por virgula e, a partir desta localização, trazer algumas informações nas demais colunas da linha (algo como o Procv faz). Abaixo um exemplo:

Coluna 1 Coluna 2 Coluna 3 Coluna 4

Linha 1 XYZ, ABC, DEF, GHI | Avenida Garibaldo S/N | Preto | Usado
Linha 2 JLM, NOP, QRS, TUV | Rua Alfonso 30 | Azul | Novo
Linha 3 AAA, BBB, CCC, DDD | Sem Rua | Vermelho | Novo

Neste caso, se procurar um valor determinado "JLM", ele localize na linha 2 e trouxesse como resultado os valores contidos na coluna 3 e Coluna 4 (com PROCV não consegui fazer funcionar pq ele não localiza mais de um valor numa mesma celula, mas a logica da formula será =PROCV(A2,<Matriz coluna 1 linha1 até coluna 4, linha 3>;3), onde A2="JLM"

Alguém teria alguma luz para me ajudar?
#61771
Utilize o PROCV() com curinga (*).
Ajuste os intervalos na fórmula conforme a localização da sua tabela.
Código: Selecionar todos
=PROCV("*"&$A2&"*";$A4:$C6;COL(B1);0)
#
Arraste uma célula para a direita para retornar a segunda coluna.
RenatinhoSantos agradeceu por isso
#61773
1. verifique se os endereços que você colocou na fórmula estão de acordo
2. verifique se na célula que contém o texto procurado (A2) existe algum caractere indesejado, como espaço no início ou no final, acento, ...

Se ainda assim você não conseguir então disponibilize diretamente aqui no fórum uma amostra do seu arquivo Excel.
RenatinhoSantos agradeceu por isso
#61775
Obrigado pela ajuda mesmo! Eu revisei e não achei nada que possa causar o erro #N/D - eu vi na planilha e o dado existe, debugei a formula, mas simplesmente da erro.
Estou anexando uma amostra dela. Se puder me orientar, eu te agradeceria muito

Observação: Mas eu desconhecia o uso de string no PROCV. Mais uma coisa que aprendi e agradeço pela sua informação!
Você não está autorizado a ver ou baixar esse anexo.
#61777
Me parece que o problema é decorrente de uma limitação do Excel relativa ao número máximo de 255 caracteres na célula que contém o valor procurado no caso da função PROCV().

Faça testes aí. Cole uma cópia desta fórmula em M2 da Planilha4 e arraste pela coluna ~~~> =NÚM.CARACT(A2)

Busquei na Planilha4 via Ctrl+L os primeiros valores procurados da Planilha2 e por acaso todos estão na célula A20, que conforme retornado pela fórmula acima, contém 399 caracteres, e devido a essa quantidade de caracteres a função PROCV() não funciona.

Agora reduza a quantidade de caracteres de A20 para menos de 255, ou coloque o valor procurado que esteja em uma célula que contenha menos de 255 caracteres, por exemplo A6, que contém 207 caracteres. Nessas duas situações as suas fórmulas deverão funcionar.

No seu caso, para contornar esse limite, experimente a fórmula matricial abaixo.

em B2
Código: Selecionar todos
=ÍNDICE(Planilha4!F$2:F$27;CORRESP(VERDADEIRO;ÉNÚM(LOCALIZAR(A2;Planilha4!A$2:A$27));0))
em D2
Código: Selecionar todos
=ÍNDICE(Planilha4!J$2:J$27;CORRESP(VERDADEIRO;ÉNÚM(LOCALIZAR(A2;Planilha4!A$2:A$27));0))
#

obs. por tratar-se de fórmula matricial, então após colar uma cópia da fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter e só depois arraste para estender pela coluna.
RenatinhoSantos, Kledison agradeceu por isso
Procurar valor em um texto

=ESQUERDA(V2;LOCALIZAR(",";V2)-1) Conseg[…]

cont.se com ext.texto

Bom dia, Estou tentando unir as fórmula[…]

Ventura , Bom dia. Obrigado pelo feedback. Fico[…]

thaisdoo , Bom dia. Obrigado pelo feedback. Fic[…]

Você não esta conseguindo porque os […]

Ajuda com botões em linhas.

Veja se esta solução ajuda. Funcion[…]

Segue uma ideia. Aplique Formataçã[…]

Boa tarde, AfonsoMira. Funciona sim... Muito obri[…]