Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por Aurea
#60805
Olá

Gostaria de saber como montar uma fórmula para não contar na soma d horas os 10 minutos antes e depois do horário de entrada e saída.

POR EXEMLO: O horário de entrada é às 8h e de saída às 18h, se eu bato o ponto entre 07h50 e 08h00, não conta como hora extra, mas se for 07:49 ele conta 11 min de hora extra. Se bato o ponto entre 08h01 e 08h10 não conta como atraso, mas se for 08h11 conta 11 minutos. Da mesma forma pra saída.

Na minha planilha não tem uma fórmula pra resolver isso, então eu sempre acho que tenho horas a mais ou a menos do que realmente é.

Da pra resolver? =D
Você não está autorizado a ver ou baixar esse anexo.
#60806
Como você não informou o horário de entrada depois do almoço, eu suponho que seja 13:12, visto que a jornada é de 08:48 horas, então na fórmula consta como TEMPO(13;12;0).
Cole em H4 e copie para baixo:
Código: Selecionar todos
=SE(CONT.NÚM(D4:G4)=0;"";SOMA(SE(E(E4>=TEMPO(12;0;0)-TEMPO(0;10;0);E4<=TEMPO(12;0;0)+TEMPO(0;10;0));TEMPO(12;0;0);E4);-SE(E(D4>=TEMPO(8;0;0)-TEMPO(0;10;0);D4<=TEMPO(8;0;0)+TEMPO(0;10;0));TEMPO(8;0;0);D4))+SOMA(SE(E(G4>=TEMPO(18;0;0)-TEMPO(0;10;0);G4<=TEMPO(18;0;0)+TEMPO(0;10;0));TEMPO(18;0;0);G4);-SE(E(F4>=TEMPO(13;12;0)-TEMPO(0;10;0);F4<=TEMPO(13;12;0)+TEMPO(0;10;0));TEMPO(13;12;0);F4)))
Good luck!
Aurea agradeceu por isso

Boa noite. Talvez este tópico seja interes[…]

@AfonsoMira , o meu aconteceu a mesma coisa. E[…]

Boa tarde, conforme o titulo, tem como puxar texto[…]

Boa noite pessoal! Eu tenho uma dúvida, e […]

Boas Obrigado pela resposta Realmente em parte o […]

Boas tudo bem, por agora só consegui resol[…]

Boa tarde! Trabalho em uma empresa e possuimos co[…]

[Ajuda] Vba criar pastas

:roll: Olá a todos estou batendo a cabe&cce[…]