Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
#60483
Boa tarde!!
Preciso de ajuda!!

Tenho uma Planilha simples de locação, eu criei duas colunas chamada, QAUTIDADE ALUGUÉIS VENCE HOJE E QUANTIDADE ALUGUEIS VENCE NO MES, e não ACHO uma fórmula que faça aparecer estes vencimentos.

Segue Planilha.

Alguém consegue me ajudar?

Obrigado!!
Você não está autorizado a ver ou baixar esse anexo.
#60489
Em i3:
Código: Selecionar todos
=SEERRO(ÍNDICE($C$3:$C$17;MENOR(SE($H$3:$H$17=DIA(HOJE());LIN($C$3:$C$17)-LIN($Z$3)+1);LIN(Z1)));"")
Para J3, a mesma fórmula, acrescentando o símbolo maior > antes do símbolo de igualdade.
Ambas são fórmulas matriciais, portanto, se o seu Excel for anterior à versão 2019, confirme com Ctrl+Shift+Enter, em vez de Enter apenas.

Good luck!
#60493
Boa tarde!!

Acho que me expliquei muito bem?

Exemplo: Locação numero1, inicio do contrato 01/01/2020 e fim do contrato 30/10/2020, Entre essas duas datas contam vencimentos todo dia 1, exemplo: 01/02/20020, 01/03/2020..... até o final do contrato que é 30/10/2020.

Eu preciso sabe se entre esses vencimentos tem algum que vence hoje e outro que vence dentro do mes.

Obrigado!!
#60508
Inovacao escreveu: 13 Nov 2020 às 19:25 Boa tarde!!

Acho que me expliquei muito bem?

Exemplo: Locação numero1, inicio do contrato 01/01/2020 e fim do contrato 30/10/2020, Entre essas duas datas contam vencimentos todo dia 1, exemplo: 01/02/20020, 01/03/2020..... até o final do contrato que é 30/10/2020.

Eu preciso sabe se entre esses vencimentos tem algum que vence hoje e outro que vence dentro do mes.

Obrigado!!
É que normalmente as pessoas digitam na célula correspondente, o resultado esperado, assim fica fácil de conferirmos se a nossa resposta está correta.

[]s
#60543
Boa tarde, stevaoba!!

Ainda não deu certo!!

Voce esta pegando a coluna "Vencimento todo dia" como referencia, essa coluna não é a referencia, ele só serve para mostra que os vencimentos dos alugueis vão ser todo dia X de cada mes.

O que voce tem que pegar como referencia são as colunas INICIO E FIM DO CONTRATO, pois dentro dessas duas datas tem os vencimentos a qual eu me refiro.

Obrigado!!
#60621
=CONT.SE(H5:H8;DIA(HOJE());E5:E8;"<="&HOJE();F5:F8;">="&HOJE())
Esta fórmula para vencimentos hoje está correta. Funcionamento passo a passo.

H5:H8;DAY(HOJE() - esse primeiro argumento é para levar em conta somente os vencimentos deste dia do mês, já que a coluna H exibe o numeral do dia do mês da coluna E.
Você tinha colocado 16, então como hoje é 18, ele vai desconsiderar todos, resultando zero.
Eu alterei os dados para vencimento 19, uma vez que o meu PC está com fuso de 3 horas adiante e já é 19/11, e o resutado foi 4.

=CONT.SE(E5:E8;"<="&DATA(ANO(HOJE());MÊS(HOJE());1);F5:F8;">="&HOJE())
Esta eu modifiquei e creio que agora vai funcionar. Funcionamento passo a passo.
Argumento 1: E5:E8;"<="&DATA(ANO(HOJE());MÊS(HOJE());1) - Confere as datas da coluna E menores ou iguais ao dia 1 do mês corrente.
Argumento 2: F5:F8;">="&HOJE() - Confere se as datas da coluna F são maiores ou iguais à data de hoje.
Favor conferir no anexo.

Ab.
Você não está autorizado a ver ou baixar esse anexo.
#60645
Boa tarde, Estevaoba!!
Entendi sua lógica, muito bom seu raciocínio!!

Só que para efeito de vencimento, eles não levam em consideram a data de inicio do contrato, pois o inquilino tem 30 dias para pagar o primeiro aluguel.

Mesmo que o inicio do contrato foi feito na data de hoje, não pode ser considerado como vencimento, mais sim os próximos vencimentos após o início do contrato.

Obrigado!!
#60652
De nada, amigo.
Realmente não tinha levado em conta esse detalhe.
Segue com ajuste a formula para vencimentos hoje:
=CONT.SES(H5:H8;DIA(HOJE());E5:E8;"<="&DATAM(HOJE();-1);F5:F8;">="&HOJE())
O argumento E5:E8;"<="&DATAM(HOJE();-1) verifica se a coluna E tem data igual ou inferior a um mês atrás.

Epara vencimentos no mês foi feita a mesma alteração:
=CONT.SES(E5:E8;"<="&DATAM(HOJE();-1);F5:F8;">="&HOJE())

Ab.
#60662
bom dia, Estevaoba!!
Tudo bem?

A formula do dia esta ok.
Agora a do mes acredito que falta um pequeno ajuste, pois fiz 4 lançamentos testes todos cm final do contato para 01/11/2020, ou seja dentro do mes 11 atual, porem ele não considerou e deixou com 0 os vencimentos do mes.

Acredito que ajustando isto, fica ok.

SEGUE PLANILHA QUE FIZ O TESTE.

Muito obrigado !!
Você não está autorizado a ver ou baixar esse anexo.

Bom dia! Estou fazendo um programinha para meu cu[…]

tenplacebo, Bom Dia. poste um modelo para que pos[…]

Ve agora Perc = DIVIDE ( COUNTROWS ( GC ); […]

Ajuste de Códigos

O Num lock está desativando por causa do ef[…]

Retornar Nº da linha

use a mesma formatação do codigo que[…]

Sub ReplicaDadosV2() Dim m As Long, k As Long […]

Bom dia. Alguém teria uma ideia / alternat[…]

ATUALIZAR DINAMICA COM CONDIÇÕES

Alguma solução pessoal?