Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Inovacao 11 Set 2020 às 23:18
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#58749
Pessoal boa noite!!

Eu tenho uma Pasta de trabalho com duas PLANILHAS, Planilha chamada de VENDAS + Planilha chamada PRODUTOS.

Na Planilha chamada PRODUTOS tem dois campos:
CAMPO1: Total de vendas Qtd.
CAMPO2: Total de vendas R$

Alguém sabe uma fórmula SIMPLES para colocar nessas colunas para que a soma seja automática? Ex: de fórmulas simples = INDIRETO, porem não consegui utiliza-la neste caso.

OBS: A Planilha tem mais de um produto na mesma venda, PRODUTO1, PRODUTO2 e etc

Segue Planilha

Obrigado.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 13 Set 2020 às 21:52
Membro 5 Estrelas
Mensagens: 784
Reputação: 371
#58794
Em B3:
Código: Selecionar todos=CONT.SE(Vendas!$A$2:$Z$17;A3)

Em C3:
Código: Selecionar todos=SOMASE(Vendas!$A$2:$Z$17;A3;Vendas!$C$2:$AB$17)

Copie para baixo.

Good luck!
Por Inovacao 14 Set 2020 às 18:37
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#58830
Boa tarde, Estevaoba!!

Maravilha deu certinho nessa Planilha, é isso mesmo que eu precisa.

Muitooooooooooo Obrigado!!

Vou pedir mais um favor se voce puder me ajudar, eu tentei reproduzir essa fórmula em outra Planilha mas não obtive sucesso, se voce puder me ajudar nesta nova Planilha eu agradeço, segue anexo.

Se não puder eu entendo e ja encerro este tópico.

Abraço!!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 15 Set 2020 às 02:32
Membro 5 Estrelas
Mensagens: 784
Reputação: 371
#58848
De nada. Fico feliz em poder ajudar.

A função SOMASES requer intervalos iguais, tanto em número de linhas como colunas.
Neste novo caso, os produtos iniciam na coluna Q e vão até a coluna BC.
Já os valores unitários iniciam na coluna S, então para manter os intervalos iguais, adicione duas colunas e o intervalo irá até a coluna BE.
Desta forma, sua fórmula será:
Código: Selecionar todos=SOMASE(LANC_ven!$Q$3:$BC$2502;I3;LANC_ven!$S$3:$BE$2502)

Para evitar erros de endereçamento, certifique-se de que a estrutura seja consistente no espaçamento entre as colunas Produto e Valor, no caso duas colunas.

Ab.
Por Inovacao 15 Set 2020 às 14:25
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#58871
Boa tarde, Estevaoba!!
Tudo bom?

Agora eu entendi, novamente deu certo, muito obrigado!! Até consegui acrescentar mais uma coluna, e ainda reproduzir em outras planilhas, show!!


Porem tem um detalhe que passou desapercebido, ela esta somando a coluna: QTD, sendo que ela devia fazer uma multiplicação das colunas QTD X VALOR UNITÁRIO.

Vou anexar a Planilha atualizada aqui, se voce puder me ajudar vai ser de grande ajuda, mas se não der entendo.

Abraços!!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 15 Set 2020 às 19:21
Membro 5 Estrelas
Mensagens: 784
Reputação: 371
#58880
Tente em H3:
Código: Selecionar todos=CONT.SE(LANC_com!$H$3:$BC$2502;J3)*PROCV(J3;LANC_com!$H$3:$J$2502;3;0)

E em I3:
Código: Selecionar todos=CONT.SE(LANC_ven!$Q$3:$BC$2502;J3)*PROCV(J3;LANC_ven!$Q$3:$S$2502;3;0)
Por Inovacao 16 Set 2020 às 11:18
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#58907
Bom dia, Estevaoba!!

Quase deu certo, porem ele só faz a multiplicação por 1, exemplo coloquei QTD=3 PREÇO= 10,00, teria que ser 60,00, mas ele não esta somando corretamente.

Segue Planilha com lançamentos no qual deveria deveria conter os seguintes resultados:

H3 = 100,00
I3= 200,00


Obrigado!!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 18 Set 2020 às 01:40
Membro 5 Estrelas
Mensagens: 784
Reputação: 371
#58971
Experimente em H3:
Código: Selecionar todos=SOMASE(LANC_com!$H$3:$BC$2502;J3;LANC_com!$I$3:$BD$2502)*PROCV(J3;LANC_com!$H$3:$J$2502;3;0)

E em I3:
Código: Selecionar todos=SOMASE(LANC_ven!$Q$3:$BC$2502;J3;LANC_ven!$R$3:$BD$2502)*PROCV(J3;LANC_ven!$Q$3:$S$2502;3;0)

Ab.
Por Inovacao 18 Set 2020 às 13:56
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#58988
Boa tarde, meu caro!!

Ainda não esta calculando de forma correta.

Fiz um exemplo que o resultado deveria ser 100,00, mas ela retornou 70,00.

Deixei exemplos na planilha
Segue novamente anexada.


Obrigado!!
Apenas usuários registrados podem ver ou baixar anexos.
Por Leonardo1234 18 Set 2020 às 14:58
Membro Novato
Mensagens: 93
Reputação: 2
#58989
Veja se está funcionando agora. Eu cortei a parte da planilha onde você repete os produtos até a coluna BC, se eu não me engano. Não tem necessidade de fazer isso com essa nova fórmula.
Apenas usuários registrados podem ver ou baixar anexos.
Por Leonardo1234 18 Set 2020 às 16:01
Membro Novato
Mensagens: 93
Reputação: 2
#58993
Se não tiver jeito e você ter que usar as colunas, você pode ir somando a fórmula e só trocar o intervalo, eu fiz essa duplicação na qual troquei o intervalo da coluna J e H pela coluna L e M. Faz a mesma coisa para as outras colunas que também da certo.

=SOMARPRODUTO((LANC_com!$I$3:$I$2502*LANC_com!$J$3:$J$2502*(LANC_com!$H$3:$H$2502=CAD_pro!J4)))+SOMARPRODUTO((LANC_com!$L$3:$L$2502*LANC_com!$M$3:$M$2502*(LANC_com!$H$3:$H$2502=CAD_pro!J4)))
Apenas usuários registrados podem ver ou baixar anexos.
Por Inovacao 19 Set 2020 às 11:02
Membro 3 Estrelas
Mensagens: 362
Reputação: 2
#59006
Boa tarde, Leonardo1234 !!

Obrigado pela ajuda, agradeço de coração, mas continuo com o mesmo problema.
A minha intenção desde o começo era achar uma única fórmula que comtemplasse todo o intervalo e somasse os 10 produtos.

Segue Planilha original em anexo.

Abraço
Apenas usuários registrados podem ver ou baixar anexos.