Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Jeczei 11 Set 2020 às 12:46
Membro Novato
Mensagens: 38
Reputação: 2
#58714
Boa tarde,
Conseguem ajudar em duas situações para soma de valores em uma matriz, dependendo de múltiplas condições e incluindo intervalo de data, pois não estou conseguindo utilizando a função "somases"...
Segue planilha para esclarecer a necessidade
Obrigado
Abs
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 11 Set 2020 às 15:47
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58735
Tente em D5 e copie para preencher a linha (Ctrl+Shift+Enter):
Código: Selecionar todos=SE(SOMASES($U5:$BY5;$U$3:$BY$3;"Qtde de Cotas";$R5:$BV5;">="&DATA(ANO(HOJE());MÊS(1&D$3);1);$R5:$BV5;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(1&D$3);1);0))=0;SE(MÊS(1&D$3)>MÊS(HOJE());0;$C5);SE($Q$5:$BU$5="Aporte";$C5+SOMASES($U5:$BY5;$U$3:$BY$3;"Qtde de Cotas";$R5:$BV5;">="&DATA(ANO(HOJE());MÊS(1&D$3);1);$R5:$BV5;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(1&D$3);1);0));$C5-SOMASES($U5:$BY5;$U$3:$BY$3;"Qtde de Cotas";$R5:$BV5;">="&DATA(ANO(HOJE());MÊS(1&D$3);1);$R5:$BV5;"<="&FIMMÊS(DATA(ANO(HOJE());MÊS(1&D$3);1);0))))

Good luck!
Por Jeczei 11 Set 2020 às 18:08
Membro Novato
Mensagens: 38
Reputação: 2
#58744
Estevaoba, quase!
A fórmula para o cálculo da data ficou perfeita, mas a soma dos valores não bate com a combinação da data e respectivos aportes e/ou resgates...
No 1o caso, no mês de JAN o valor correto seria 16.000,00 (10+15-9) e em FEV seria -20.000,00...
Obrigado
Abs
Avatar do usuário
Por Estevaoba 11 Set 2020 às 19:01
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58746
Fica difícil incluir essa nova condição na SOMASES, porque o critério está na mesma linha dos valores da soma.
Se puder, ao digitar, coloque o sinal menos antes do valor quando for resgate.
Ou adicione uma coluna para valores de resgate em cada grupo de evento.

Ab.
Por Jeczei 11 Set 2020 às 19:58
Membro Novato
Mensagens: 38
Reputação: 2
#58747
Estevaoba,
Encontrei uma saída que foi separar os filtros de aporte e resgate, somando ou subtraindo na mesma sentença. Deu certo!
Muito obrigado pela rápida ajuda.
bom fds