Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Guibarbosa7 10 Set 2020 às 13:35
Membro Novato
Mensagens: 21
Reputação: 0
#58665
Boa tarde pessoal estou com um relatório onde tenho varios itens duplicados por exemplo:

eu tenho as 13hrs continuacao de viagem, dps as 13h :10 continuacao de viagem , tenho esses itens em duplicidade mas preciso considerar o menor , e não consigo pensar em nada que poça resolver a minha situação, estou disponibilizando um anexo com exemplo.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Deciog 11 Set 2020 às 08:29
Membro 5 Estrelas
Mensagens: 1547
Reputação: 823
#58698
Guibarbosa7, Bom Dia.

Estou com duvida qual resultado você quer, pode digitar um resultado esperado para que possamos fazer a formula

Decio
Avatar do usuário
Por Estevaoba 11 Set 2020 às 09:27
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58699
Fiz de duas formas:
Na coluna A com formatação condicional, marco as datas/horários conforme a condição desejada.
E na coluna E listo endereços únicos com filtro avançado para exibir ao lado a primeira ocorrência de CONTINUACAO DE VIAGEM.
Alguns endereços na coluna B são parecidos, e podem exibir resultados indesejados nessas fórmulas.
Se não funcionar, é porque o seu Excel é versão anterior à 365. Nesse caso poderemos modificar as fórmulas.
Favor conferir no anexo.

Good luck!
Apenas usuários registrados podem ver ou baixar anexos.
Por Guibarbosa7 11 Set 2020 às 14:22
Membro Novato
Mensagens: 21
Reputação: 0
#58720
Então eu tenho uma base de dados onde preciso fazer INICIO DE VIAGEM - CONTINUAÇÂO DE VIAGEM, mas acontece que tenho varios valores igual a CONTINUAÇÂO DE VIAGEM e o que tenho que subtrair do INICIO DE VIAGEM é o CONTINUAÇÂO DE VIAGEM que contém a menor dada
Avatar do usuário
Por Estevaoba 11 Set 2020 às 14:43
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58726
Faltou informar a versão do seu Excel.
Em todo caso, tente esta fórmula em E1 e copie para baixo:
Código: Selecionar todos=SE(C1="INICIO DE VIAGEM";MÍNIMOSES($A$1:$A$16;$B$1:$B$16;B1;$C$1:$C$16;"CONTINUACAO DE VIAGEM")-A1;"")

Ab.
Avatar do usuário
Por Estevaoba 11 Set 2020 às 14:51
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58731
Obrigado, Guibarbosa7.

Segue adaptação da fórmula para versões anteriores. Trata-se neste caso de fórmula matricial e deve ser confirmada com Ctrl+Shift+Enter, em vez de Enter apenas:
Código: Selecionar todos=SE(C1="INICIO DE VIAGEM";MÍNIMO(SE($B$1:$B$16=B1;SE($C$1:$C$16="CONTINUACAO DE VIAGEM";$A$1:$A$16)))-A1;"")

Ab.
Por Guibarbosa7 12 Set 2020 às 08:57
Membro Novato
Mensagens: 21
Reputação: 0
#58759
Estevaoba, olha como fica os resultados quando apliquei na base toda, ve se estou fazendo algo de errado
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 13 Set 2020 às 02:45
Membro 5 Estrelas
Mensagens: 787
Reputação: 373
#58768
Notei que as células com o texto CONTINUACAO DE VIAGEM contêm caracteres a mais do que se pode ver, no caso espaço e nova linha. Não sei se todas são idênticas. Por isso a função MÍNIMO com a condicional SE($C$1:$C$8000="CONTINUACAO DE VIAGEM" retorna zero e o resultado da fórmula, uma data negativa.
Para observar isso, clique duplo em qualquer célula com esse texto e tecle Ctrl+A.
Até aí tudo bem. Basta usar na fórmula a referência a uma célula fixa com esse texto, =$C$2 por exemplo, contanto que todas as células com o texto CONTINUACAO DE VIAGEM sejam idênticas.
O problema maior é que existem também valores duplicados de data/hora alinhados com INICIO DE VIAGEM, antes de um evento CONTINUACAO DE VIAGEM e isso dificulta identificar corretamente o primeiro evento subsequente de CONTINUACAO DE VIAGEM para fazer a subtração como você precisa.
Realmente muito complicado trabalhar com dados assim.