Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Inovacao 01 Ago 2020 às 14:16
Membro 3 Estrelas
Mensagens: 316
Reputação: 2
#57631
Pessoal boa tarde!!

Tenho uma Planilha de contas a pagar com base de dados de Janeiro a Dezembro com uma coluna chamada SALDO.

Tenho outra planilha chamada fornecedores, a qual tem uma coluna chamada SALDO DEVEDOR e outra coluna chamada EMPRESA, a qual eu filtro o nome da empresa, e que deveria somar os valores na coluna SALDO dos meses pela empresa filtrada.

Para facilitar eu coloquei em amarelo a coluna que precisava que somasse, pois eu seleciono a empresa e não muda os valores.

Alguém consegue me ajudar?

Segue Planilha em anexo.

Desde já obrigado!!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 01 Ago 2020 às 22:56
Membro 5 Estrelas
Mensagens: 728
Reputação: 349
#57634
A SOMASE na sua fórmula não faz referência às colunas de empresas.
Eu a substituí pela SOMASES e ficou assim em E7:
Código: Selecionar todos=SE(B7="";0;SOMARPRODUTO(SOMASES(INDIRETO("'"&ZZZ&"'!I13:I22");INDIRETO("'"&ZZZ&"'!D13:D22");$C$3;INDIRETO("'"&ZZZ&"'!C13:C22");B7)))

Good luck!